"Link Contacts" and then close facebook can block the contacts app for > 2 minutes without a way to cancel

RESOLVED DUPLICATE of bug 796604

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 796604
6 years ago
6 years ago

People

(Reporter: bjacob, Unassigned)

Tracking

({b2g-testdriver, unagi})

Firefox Tracking Flags

(Not tracked)

Details

STR:

 - go you some of your contacts
 - touch the "link contacts" button
 - it takes you to m.facebook.com and asks you to log in to Facebook.
 - suppose I'm not interested and want to go back. I then touch the 'x' button at the top-left to close that Facebook login page.
 - now it says "Hold on. We are connecting to obtain your friend list" and "This may take a coupe of minutes".
 - I can go back to homescreen, but I can't use the Contacts app at all while this happens.
 - I waited over 2 minutes and nothing happened
 - There is no 'cancel' button
 - Only way I found was to restart b2g.
(Reporter)

Comment 1

6 years ago
Note: I am not logged in to Facebook. That might be key to why I'm getting this bug and other people might not.

Updated

6 years ago
Status: NEW → RESOLVED
blocking-basecamp: ? → ---
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 796604
You need to log in before you can comment on or make changes to this bug.