Last Comment Bug 807787 - Folder pane (tree widget) on linux wastes horizontal space
: Folder pane (tree widget) on linux wastes horizontal space
Status: RESOLVED FIXED
: regression
Product: Thunderbird
Classification: Client Software
Component: Folder and Message Lists (show other bugs)
: Trunk
: x86_64 Linux
: -- minor (vote)
: Thunderbird 19.0
Assigned To: Richard Marti (:Paenglab)
:
Mentors:
Depends on:
Blocks: 689543
  Show dependency treegraph
 
Reported: 2012-11-01 13:34 PDT by Jonathan Protzenko [:protz]
Modified: 2012-11-07 14:54 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Before (4.79 KB, image/png)
2012-11-01 13:34 PDT, Jonathan Protzenko [:protz]
no flags Details
After (4.67 KB, image/png)
2012-11-01 13:34 PDT, Jonathan Protzenko [:protz]
no flags Details
patch (1.09 KB, patch)
2012-11-02 04:49 PDT, Richard Marti (:Paenglab)
bugs: review-
bugs: ui‑review-
Details | Diff | Review
text overflows all folders with new messages (9.61 KB, image/png)
2012-11-06 04:58 PST, Andreas Nilsson (:andreasn)
no flags Details
patch v2 (1.50 KB, patch)
2012-11-06 09:08 PST, Richard Marti (:Paenglab)
bugs: ui‑review+
Details | Diff | Review
patch v3 (1.63 KB, patch)
2012-11-07 10:12 PST, Richard Marti (:Paenglab)
bugs: review+
richard.marti: ui‑review+
Details | Diff | Review

Description Jonathan Protzenko [:protz] 2012-11-01 13:34:28 PDT
Created attachment 677544 [details]
Before

(I was sure I filed this a year ago but apparently I forgot to do it -- I'm feeling the pain now that I'll be running without my 24'' monitor for a few weeks).

Approximately a year ago, Thunderbird started using a whole lot more horizontal space for its folder tree, namely around the icon and left of the label. I'm attaching two screenshots for comparison.

I'm using a vertical layout on a 1600x1050 screen, so this kinda wastes space, both in the folder list and the thread pane (thread triangles waste the same amount of space).

Any idea what can cause this?
Comment 1 Jonathan Protzenko [:protz] 2012-11-01 13:34:53 PDT
Created attachment 677545 [details]
After
Comment 2 Jonathan Protzenko [:protz] 2012-11-01 13:35:43 PDT
Richard, I'm CCing you because as the theme expert you may have ideas :). If you think this is not Thunderbird-related (this may well be the case) feel free to reassign to Core/XUL.
Comment 3 Richard Marti (:Paenglab) 2012-11-01 15:14:27 PDT
Bug 689543 introduced a 5px margin before the label. I'll try to fix this.
Comment 4 Jonathan Protzenko [:protz] 2012-11-01 19:52:34 PDT
Oh that would be fantastic!
Comment 5 Richard Marti (:Paenglab) 2012-11-02 04:49:10 PDT
Created attachment 677720 [details] [diff] [review]
patch

I gave the cell-text in the folder pane a padding of 1px to have still a small gap between icon and text.
Comment 6 Jonathan Protzenko [:protz] 2012-11-04 08:20:06 PST
Thinking about it, do we also need the extra space between the tree twisty and the subject?

http://jonathan.protzenko.free.fr/shutter/Selection_042.png

I feel like we would benefit from removing the space left of the "[" brackets (as seen in the screenshot) but there may be a good reason not to do so. I guess it really is a matter of personal preference, so please take my question as begin a curious "why are we doing it that way?" rather than a "I think we should change this!" sort of thing :).
Comment 7 Jonathan Protzenko [:protz] 2012-11-04 08:21:04 PST
Oh and I found the answer myself, we need the space for the "replied to / forwarded" icons :)
Comment 8 Andreas Nilsson (:andreasn) 2012-11-06 04:57:52 PST
Comment on attachment 677720 [details] [diff] [review]
patch

This looks more crowded. I agree that we can decrease the spacing some, but not this much. It also seems to break folders with new messages in them. See attached screenshot.
Comment 9 Andreas Nilsson (:andreasn) 2012-11-06 04:58:59 PST
Created attachment 678709 [details]
text overflows all folders with new messages

This is a catch-all-address for a certain domain, so a lot of unread spam :)
Comment 10 Richard Marti (:Paenglab) 2012-11-06 05:10:56 PST
(In reply to Andreas Nilsson (:andreasn) from comment #8)
> Comment on attachment 677720 [details] [diff] [review]
> patch
> 
> This looks more crowded. I agree that we can decrease the spacing some, but
> not this much. It also seems to break folders with new messages in them. See
> attached screenshot.

Oops, then the new message rule needs also a padding change.

Would be 2px for spacing better? Then we have gained 3px.
Comment 11 Andreas Nilsson (:andreasn) 2012-11-06 05:12:36 PST
That sounds good to me!
Comment 12 Richard Marti (:Paenglab) 2012-11-06 09:08:08 PST
Created attachment 678774 [details] [diff] [review]
patch v2

Now with correct new mail display.
Comment 13 Andreas Nilsson (:andreasn) 2012-11-07 05:21:17 PST
padding-left: 18px !important; on 244
How come it needs !important here? Always good to avoid !important if possible.
Comment 14 Andreas Nilsson (:andreasn) 2012-11-07 05:21:49 PST
Comment on attachment 678774 [details] [diff] [review]
patch v2

ui looks good!
Comment 15 Richard Marti (:Paenglab) 2012-11-07 10:12:21 PST
Created attachment 679229 [details] [diff] [review]
patch v3

Now without !important.

Carrying over ui-r+
Comment 16 Andreas Nilsson (:andreasn) 2012-11-07 11:24:51 PST
Comment on attachment 679229 [details] [diff] [review]
patch v3

Thanks for getting rid of the !important
Comment 17 Ryan VanderMeulen [:RyanVM] 2012-11-07 14:54:18 PST
https://hg.mozilla.org/comm-central/rev/8dbefac39d8c

Note You need to log in before you can comment on or make changes to this bug.