Chat window is broken when the Social API sidebar is hidden

RESOLVED DUPLICATE of bug 805071

Status

()

RESOLVED DUPLICATE of bug 805071
6 years ago
6 years ago

People

(Reporter: simona.marcu, Unassigned)

Tracking

17 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 677764 [details]
Screenshot

Mozilla/5.0 (Windows NT 6.2; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

The chat window doesn't behave in the same way when the sidebar is hidden or shown. 

Reproducible:always

Steps to reproduce:
1. Launch Firefox, log into your Facebook account and activate Social API feature
2. Go to the Facebook button in the Navigation bar and uncheck the Show Sidebar option
3. Launch Firefox with a different profile and log into a different Facebook account from the one in step 1
3.1. Chat with the user from step 1.

Expected results:
The chat window when the sidebar is hidden, behaves in the same way as it does when the sidebar is shown.

Actual results:
1. The chat window is not opened at the beginning of the conversation (it's minimized). 
2. The text input box is not displayed at all in the chat window. After the first click on the window's content, the text input box jumps out.
3. The Settings button, that is located in the upper right corner of the chat window, is not displayed all the time even if the chat window is in focus. The Settings button is not displayed after the first click on the window's content and reappears again - but cut off - after writing something in the text input box.
(In reply to Simona B [QA] from comment #0)
> 1. The chat window is not opened at the beginning of the conversation (it's
> minimized). 

I think this is a limitation we enforce, to prevent the provider from opening full chat windows when users aren't expecting it.

> 2. The text input box is not displayed at all in the chat window. After the
> first click on the window's content, the text input box jumps out.
> 3. The Settings button, that is located in the upper right corner of the
> chat window, is not displayed all the time even if the chat window is in
> focus. The Settings button is not displayed after the first click on the
> window's content and reappears again - but cut off - after writing something
> in the text input box.

This is probably caused by an existing issue with Facebook's handling of collapsed chats - I think there's a bug on this already.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 805071
You need to log in before you can comment on or make changes to this bug.