Persona login is broken when marketplace serves double slash URLs

RESOLVED DUPLICATE of bug 813171

Status

Marketplace
Consumer Pages
RESOLVED DUPLICATE of bug 813171
5 years ago
5 years ago

People

(Reporter: Bebe, Unassigned)

Tracking

x86_64
Linux
Points:
---

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 677776 [details]
screenshot with the error page

Open https://marketplace-dev.allizom.org/developers/
Click Login

Expected
User should login as expected.

Actual:
Our tests return a browserId error message

http://qa-selenium.mv.mozilla.com:8080/job/marketplace.dev.developer_hub/154/HTML_Report/?
(Reporter)

Comment 1

5 years ago
This is not reproducible logging in manually

Comment 2

5 years ago
steps to reproduce:

1. open https://marketplace-dev.allizom.org//developers/
2. click login

notice the double slash in the url

problem description:
  * tests are invoked with --baseurl=https://marketplace-dev.allizom.org/
  * pom stuff creates urls with double slashes in the path https://github.com/lloyd/marketplace-tests/blob/master/pages/desktop/developer_hub/home.py#L18
  * marketplace happily serves up content with double slashes
  * persona hates double slashes https://github.com/mozilla/browserid/blob/dev/resources/static/dialog/js/modules/dialog.js#L110

On the persona side I will investigate why we are hating on double slashes.

On the marketplace side there are several ways to resolve:
1. redirect users from //foo to /foo
2. remove trailing slash in base_url
3. change test code to dedup slashes
Good catch, thanks. We should at least redirect //foo to /foo to prevent this from happening. The selenium tests should also be updated.
Component: Developer Pages → Consumer Pages
Summary: [DEV] BrowserID login is returns error message → Persona login is broken when marketplace serves double slash URLs

Comment 4

5 years ago
for completeness, here is where the change was introduced that got us hating double slash '//': https://github.com/mozilla/browserid/pull/2480

Comment 5

5 years ago
How is this related to double slashes? The problem reproduces without the double slashes. This error is occurring because /browserid-login throws a 403.
(Reporter)

Comment 6

5 years ago
I will update the tests to use single slash url and will add a special login testcase that will check that a user can login if he uses a double slash url
(Reporter)

Comment 7

5 years ago
Fix and new test for our tests

https://github.com/mozilla/marketplace-tests/pull/166
Florin filed another more generic bug.  It's the same thing, so duping to that.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 813171
You need to log in before you can comment on or make changes to this bug.