Sometimes pages with fixed viewport size get resized horizontally after visiting another page which is not viewport size

RESOLVED DUPLICATE of bug 803719

Status

()

RESOLVED DUPLICATE of bug 803719
6 years ago
6 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I've seen this on google reader and I think it's a regression from reflow on zoom.

Sometimes when I open a link in google reader and view an article which is not viewport sized, and then go back to the reader page, the page is now wider than the viewport, and can be horizontally scrolled.

I'm not sure how to reproduce this exactly.

Comment 1

6 years ago
STR:
0. I have text size set to tiny and pinch to reflow text enabled.
1. In one tab, visit bugzilla.mozilla.org. It's zoomed out.
2. Open a new tab to example.com. It's also zoomed out.
3. Pinch zoom in on example.com. The text reflows.
4. Switch to the bugzilla tab.

Expected:
still zoomed out

Actual:
the page is all narrow
Ah yes I can reliably reproduce this too.  My STR are similar to comment 1:

1. Open http://i.reddit.com/ and notice its fixed viewport width.
2. Open a tab in the background, e.g. by long tapping one of the Reddit links and choosing Open in New Tab.  (Links to http://i.imgur.com/ repro this bug reliably.)
3. Switch to the newly opened tab.
4. Ping to zoom in on the new tab.
5. Switch back to the original tab.
6. Notice that the text is wrapped narrower than the screen width now, but that the page width is wider than the screen width.

You can actually see the thumbnail of the i.reddit.com tab update to its incorrect width when in step 5 you tap the tab switching button.
Scott, do you know if this is related to font inflation at all? (I haven't tried to reproduce this yet but I can try with/without font inflation if you don't know off the top of your head).
Flags: needinfo?(sjohnson)
OS: Mac OS X → Android
Hardware: x86 → All
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #3)
> Scott, do you know if this is related to font inflation at all? (I haven't
> tried to reproduce this yet but I can try with/without font inflation if you
> don't know off the top of your head).

Yeah, so this is fixed by the patch in bug 803719. It's part of the fix where we weren't using the selected tab correctly when performing reflow-on-zoom.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(sjohnson)
Resolution: --- → DUPLICATE
Duplicate of bug: 803719
You need to log in before you can comment on or make changes to this bug.