Skype click-to-call extension not working with FF17, works with all prev versions.

RESOLVED INVALID

Status

()

Firefox
Extension Compatibility
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: rama kurvakat, Unassigned)

Tracking

17 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 677848 [details]
Skype_C2C_addon_issue_with_FF17.docx

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.94 Safari/537.4

Steps to reproduce:

1. Installed Firefox 17
2. recompiled Skype click-to-call add-on with gecko17 since its a binary component.
3. installed the add-on.
4. it does not complain now that its incompatible but then it does not function as expected. The plugin has a button on the toolbar that when clicked shows a window with options, but now it doesn't show anything.

The investigation I've done is attached as a document below.




Expected results:

1. The installed add-on displays a button on the toolbar which when clicked shows a list of options.
With Firefox17 it shows nothing when clicked.

2. the add-on should highlight phone numbers, for example if you google for 1-800-COMCAST you should see phone numbers being highlighted with a small blue skype icon next to it.
(Reporter)

Updated

5 years ago
Component: Untriaged → Extension Compatibility
(Reporter)

Comment 1

5 years ago
we were using 

netscape.security.PrivelegeManager in our javascript hook that triggered the creation of the binary component registered by our dll.

the PrivelegeManager seems to be working until FF16 but from FF17 onwards seems like there is an issue.
Anyways this is resolved now thanks to Mozilla support !
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.