Calendar only shows a subset of events

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Calendar
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: mushi, Unassigned)

Tracking

({b2g-testdriver, unagi})

unspecified
x86
Mac OS X
b2g-testdriver, unagi

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Reporter)

Description

6 years ago
My imported zimbra calendar shows what seems to be an arbitrary subset of my events. November currently only has one showing, but in reality there are multiple events every day. 

I've had this problem since I first got the phone. Just flashed it because of a different problem and I'm still experiencing the same problem.

Updated

6 years ago
Component: Gaia → Gaia::Calendar
Maria, can you provide some details on what events are missing? (Are they recurring, all day in a different timezone, etc...)
(Reporter)

Comment 2

6 years ago
(In reply to James Lal [:lightsofapollo] from comment #1)
> Maria, can you provide some details on what events are missing? (Are they
> recurring, all day in a different timezone, etc...)

I haven't been able to find a pattern, right now it looks like almost all (but not exactly all) of all my events missing, spread across the board. 

An example from this week: One event is shown, it's an invitation to a lunch with an interview candidate, so a one time event, with multiple invitees. The calendar is *not* showing:

- Weekly recurring events created by me or others.
- Single instance events created by me or others
- Single instance events created by the same owner as that one lunch that is showing up.
blocking-basecamp: ? → -
Keywords: qawanted
Maria - I'll followup with you directly to get more information on this when i get back in office next week.
QA Contact: tchung → jsmith
I'm going to suggest we re-test this after the new iCal parser lands. After that lands, if you can still reproduce, then let's figure out what happened.
Keywords: qawanted
Maria - Can you retry with your zimbra calendar? The new ical parser has landed, so let's see what issues you run into now.
Flags: needinfo?(msandberg)
(Reporter)

Comment 6

5 years ago
(In reply to Jason Smith [:jsmith] from comment #5)
> Maria - Can you retry with your zimbra calendar? The new ical parser has
> landed, so let's see what issues you run into now.

Flashed my phone and it's working much better now. It seems to be pulling the events correctly, haven't done a super thorough look through yet but so far so good. Thanks!
Flags: needinfo?(msandberg)
Awesome. Feel free to file any new bugs if you hit any issues. Thanks for the help testing!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.