In Display settings, the icons for brightness slider seem flipped to people

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
P4
normal
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: lco, Assigned: ivanovpavel)

Tracking

unspecified

Firefox Tracking Flags

(b2g18 fixed)

Details

(Whiteboard: visual design, visual-tracking, uxbranch, landed in uxbranch; qa-verified)

Attachments

(6 attachments, 2 obsolete attachments)

(Reporter)

Description

6 years ago
Created attachment 677957 [details]
Brightness slider

In general feedback, people were not sure which icon dimmed the screen and which icon made it brighter. Currently, the left icon dims the screen, but it looks visually "brighter" because it's lighter in color and is hollow. The right icon increases brightness, but it looks visually "darker" because it's darker in color and is filled in.

Updated

6 years ago
Component: Gaia → Gaia::Settings
Whiteboard: visual design
Assignee: nobody → epang
Priority: -- → P4
Created attachment 683117 [details]
Brightness Icons

why don't we use the same icon twice, but change the size to signify increasing/decreasing the brightness. I can export the icons if needed.
Created attachment 684056 [details]
Brightness Mock Ups

We have 2 solutions to the issue (labelled on mock up):

1. Sun icon with number - This solution is preferred if possible.

2. Brightness adjustment with Moon (lower) and Sun (higher) icons.  Only if solution one is not possible.
Attachment #683117 - Attachment is obsolete: true
Created attachment 684058 [details]
Icons for brightness adjustment

Updated

6 years ago
Assignee: epang → samuel
(Reporter)

Comment 4

6 years ago
I don't know if we decided on #2, but I did like #1 better. #1 Has a slight problem of people not thinking of brightness as a number though.

With #2, I am slightly worried that people will interpret this as day or night mode, and think the screen would be brighter in night mode :P

Anyway, this isn't a blocker for me. If people decided while I was away, I'm ok with that.
Created attachment 693480 [details]
Icons for brightness adjustment

Updated the higher brightness icon to match the one in settings.
Attachment #684058 - Attachment is obsolete: true
Whiteboard: visual design → visual design, uxbranch
Assignee: sjochimek → pivanov
Attachment #693480 - Flags: feedback?(padamczyk)
Attachment #693480 - Flags: feedback?(lco)

Comment 7

5 years ago
Landed in UX Branch https://github.com/gordonbrander/gaia/commit/546d87666adf3c22eb66d7e7629654afe7487da7
Whiteboard: visual design, uxbranch → visual design, uxbranch, landed in uxbranch
Whiteboard: visual design, uxbranch, landed in uxbranch → visual design, uxbranch, landed in uxbranch; qa-verified

Comment 8

5 years ago
Here is the js part to fix the bug. 
Landed in UX Branch: https://github.com/gordonbrander/gaia/commit/f2abb84a855e020330257578128a6a6d6ac650a4
Flags: needinfo?(nhirata.bugzilla)
I verified the follow up patch, it will still need to be pushed : 
https://github.com/gordonbrander/gaia/commit/f2abb84a855e020330257578128a6a6d6ac650a4
Status: RESOLVED → REOPENED
Flags: needinfo?(nhirata.bugzilla)
Resolution: FIXED → ---

Comment 11

5 years ago
Vivien,

Just to ping you that the fix has been PRd with the UX weekly commits.

https://github.com/mozilla-b2g/gaia/pull/7704

;-)
Flags: needinfo?(21)
https://github.com/mozilla-b2g/gaia/commit/5cb6a64dbf643e2c8774f4aadedd57a6e0d6dafb
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Flags: needinfo?(21)
Resolution: --- → FIXED
Attachment #693480 - Flags: feedback?(padamczyk)
Master build : 2013-03-25-03-07-06
"mozilla-central" revision="bef19bca23f9"
"integration/gaia-central" revision="8c401e09a6a9"
"gecko.git"revision="bbaac6bbbf5084ef1a3e178ced676ea77db8b24b"
"gaia.git" revision="a1259a6c80629daa458428d6a96403841aaab0f0"

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/dec694d585e1
Gaia   5a31a56b96a8fc559232d35dabf20411b9c2ca1d
BuildID 20130325070203
Version 18.0
Unagi
Status: RESOLVED → VERIFIED
status-b2g18: --- → verified
Mistakenly set this to verify for master:

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/dec694d585e1
Gaia   5a31a56b96a8fc559232d35dabf20411b9c2ca1d
BuildID 20130325070203
Version 18.0
unagi 

Can't verify in master due to bug 854138
Status: VERIFIED → RESOLVED
Last Resolved: 5 years ago5 years ago
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #14)
> Mistakenly set this to verify for master:
> 
> Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/dec694d585e1
> Gaia   5a31a56b96a8fc559232d35dabf20411b9c2ca1d
> BuildID 20130325070203
> Version 18.0
> unagi 
> 
> Can't verify in master due to bug 854138

Hi Naoki, what's holding this bug from being verified?
The previous hold up was that there was a bug that caused the settings panel not to show.  

Currently, it's regressed and I'm showing a difference between master and v1 train.  bug 858698
Side note : sliders are not working correctly in master : bug 854469
Figured out why it's showing the moon on today's version versus the unfilled sun.  Today's version isn't using the @2x.png : 
https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/style/images/range_icons_brightness_min%402x.png

Can we get that updated please?

The non-hidpi is showing correctly : https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/style/images/range_icons_brightness_min.png
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to Naoki Hirata :nhirata (please use needinfo instead of cc) from comment #18)
> Figured out why it's showing the moon on today's version versus the unfilled
> sun.  Today's version isn't using the @2x.png : 
> https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/style/images/
> range_icons_brightness_min%402x.png
> 
> Can we get that updated please?
> 
> The non-hidpi is showing correctly :
> https://github.com/mozilla-b2g/gaia/blob/master/apps/settings/style/images/
> range_icons_brightness_min.png

Hi Naoki, just need a little clarification on what's needed.  Is it the @2x pngs of the sun and moon?  Let me know and I'll attached and flag Pavel to help fix. Thanks!
Flags: needinfo?(nhirata.bugzilla)
Hi epang, just @x2 version of the moon.
Flags: needinfo?(nhirata.bugzilla) → needinfo?(epang)
Created attachment 737624 [details]
@2x Moon Icon (lower brightness)

Hi Naoki, I've attached the @2x Moon icon :)
Flags: needinfo?(epang)
Pavel, can you update this icon on the hdpi version? Thanks!
Flags: needinfo?(pivanov)
Created attachment 737872 [details]
patch for Gaia repo
Attachment #737872 - Flags: review?(sjochimek)
Flags: needinfo?(pivanov)

Comment 24

5 years ago
Comment on attachment 737872 [details]
patch for Gaia repo

Followup landed in master https://github.com/mozilla-b2g/gaia/commit/b65dbaace1bfc940db6f10aee6ad3c54187d25aa
Attachment #737872 - Flags: review?(sjochimek) → review+
Verified on:
## Environment :
BuildID : 2013-04-25-03-09-50
"mozilla-central" revision="690b5e0f6562"
"gecko.git" revision="33f9b3898b66dfb95874866269463d4b6bc749a0"
Unagi
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Comment 26

5 years ago
Comment on attachment 737872 [details]
patch for Gaia repo

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Slider thumb are not rendering well.
User impact if declined: May see broken slider
Testing completed: Yes 
Risk to taking this patch (and alternatives if risky): low, assets updates and css rules redefine
String or UUID changes made by this patch: -
Attachment #737872 - Flags: approval-gaia-v1?(21)

Updated

5 years ago
Attachment #737872 - Flags: approval-gaia-v1?(21) → approval-gaia-v1+
Sam, has this been uplifted to V1 Train?  If not, what needs to be done to have this uplifted?
Flags: needinfo?(sjochimek)

Comment 28

5 years ago
I just checked that: 

- 812bd047c5c70794d1a0d481047e6578db0a1ff2 already in v1-train
- 5cb6a64dbf643e2c8774f4aadedd57a6e0d6dafb already in v1-train too

Uplifed b65dbaace1bfc940db6f10aee6ad3c54187d25aa -> 64b1a7b339acb21c3f074184a4e7284953856647 in v1-train

I notice that the js fix of this bug has been fixed here https://bugzilla.mozilla.org/show_bug.cgi?id=830782.
status-b2g18: verified → fixed
Flags: needinfo?(sjochimek)

Updated

5 years ago
Whiteboard: visual design, uxbranch, landed in uxbranch; qa-verified → visual design, visual-tracking, uxbranch, landed in uxbranch; qa-verified
You need to log in before you can comment on or make changes to this bug.