Status

--
critical
RESOLVED WORKSFORME
18 years ago
10 years ago

People

(Reporter: c, Assigned: namachi)

Tracking

Trunk
mozilla0.9.1
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
In mozilla-win32-talkback-2001-05-12-10.zip talkback does not work.
First I installed it over an older build (2001-05-02-12) and it seemed to work,
but it reported the old build ID (noticed by report pasted into bug 75662).
Then I installed into a fresh directory, deleted mozregistry.dat and entries in
Windows registry, and talkback didn't work at all.

Comment 1

18 years ago
It's not working under linux either.I get the following error:

 Hey : You are in QFA Startup 
(QFA)Talkback error: Can't initialize.

As a side question: Am I better off filing a bug report for crashes or just
letting talkback submit it with appropiate comments?
(Reporter)

Comment 2

18 years ago
Works for me with mozilla-win32-talkback-2001-05-16-05.zip .
(Assignee)

Comment 3

18 years ago
*** Bug 81216 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
I see this on linux. I'm using 2001051821, which I installed using the
installer.  I installed to a new directory and created a new profile.

Comment 5

18 years ago
i cant get talkback to work in any post 0.9 build
0.9 works fine
(Using Linux)

Updated

18 years ago
Severity: normal → critical
OS: All → Linux
Hardware: All → PC
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 6

18 years ago
Investigating the problem. As a workaround please use libqfaservices.so and 
qfaservices .xpt from M0.9 builds(or any older builds ).

Status: NEW → ASSIGNED

Comment 7

18 years ago
No wonder it does not work!
libqfaservices.so and qfaservices .xpt are missing from ./mozilla/components/
dir! 0.9 has them
Are you sure those are the only 2 files needed? I am suspecting the problem is
in the xpi installer. Since i can make the browser crash at will :) this will
prove a great help if we get talkback fixed

(Assignee)

Comment 8

18 years ago
Talkback enabled builds will contain following files :

 Under components directory :-
     libqfaservices.so
     qfaservices.xpt
     talkback/XTalkback.ad
     talkback/talkback
     talkback/talkback.so
   
Only dynamic file is 
     talkback/master.ini
(This needs to be current and changes for every build)



Comment 9

18 years ago
This is juuuuuuust great. I copied all that files and restarted mozilla.Now i get this:usr/local/mozilla/run-mozilla.sh: line 72:  6245 Segmentation fault      $prog${1+"$@"}I erased them back, and still the same. This has happened me before. I need to reboot and hope for a miracle that it would work (that's how it got fixed the last time, without doing anything)The problem is that i cant currently restart my machine, and not for the whole dayPlease some user continue with the tests.I suspect the installer is just not installing talkback at installation (which would explain why crashing does not launch anything)
(Assignee)

Comment 10

18 years ago
More update :-

   There seems to be a change in the directory hierarchy for the components
which is affecting talkback. If you move talkback directory(entire directory)
to one level above(same level as components directory) then Talkback seems
to work fine. 

Talkback Initialization code is looking for talkback.so in <Installed Directory> 
bin/talkback.so or bin/talkback/talkback.so. Since, the talkback directory is
under components directory it is not able to find the library. 

This problem might have been started by the makefiles changes happened three 
weeks back. 

Comment 11

18 years ago
What about the libqfaservices.so qfaservices.xpt files? Should they remain in
the components dir?
I have moved the dir at same level of components, now if only i could make
mozilla crash :)
(Assignee)

Comment 12

18 years ago
libqfaservices.so and qfaservices.xpt needs to be in the components directory.

Comment 13

18 years ago
Build 2001051821
On my /usr/local/mozilla dir i have a talkback dir, with the files:
XTalkback.ad  master.ini  talkback*  talkback.so* 
On the components dir i have libqfaservices.so and qfaservices.xpt

After i did this, i closed mozilla and restarted. After looking for mozilla to
crash :) i did, but talkback didn't launch

Maybe i need a new master.ini since it's dynamic and i got the one from 0.9?
(Assignee)

Comment 14

18 years ago
If you are building it locally then talkback will not be useful. If you are
installing the talkback enabled mozilla build then moving the talkback directory
will work. 

 Are you seeing the messages in the console ? Does it say talkback loaded ok ?

Comment 15

18 years ago
I am installing with talkback enabled, then moving the dir to the place you
mentioned. I will try a newer build later

Comment 16

18 years ago
Ok people. More info
Check this out:
-rw-r--r--    1 11191    wheel      833156 May  7 15:33 talkback.xpi    
That's 0.9

And this one:
-rw-r--r--    1 espectro espectro      539 May 22 18:08 talkback.xpi   
That's any 0.9+ build.

If i unzip the "bad" one, only one .js file will show up
If i unzip the "good" one, i get: 
 inflating: bin/components/talkback/XTalkback.ad
  inflating: bin/components/talkback/master.ini
  inflating: bin/components/talkback/talkback
  inflating: bin/components/talkback/talkback.so
  inflating: bin/components/libqfaservices.so
  inflating: bin/components/qfaservices.xpt
  inflating: install.js

Moving the dirs and the files from 0.9 to the new builds does not work for me
(Assignee)

Comment 17

18 years ago
ccing samir and ssu. Do you guys know anything about this problem ?

Comment 18

18 years ago
Please mark this bug as dup of 54579

I am inside the initialize
 Hey : You are in QFA Startup
(QFA)Talkback loaded Ok.

Build 2001052606
This is as good as closed, good work

Comment 19

18 years ago
Bad news people.
My last message said that talkback loaded ok, well, just partly, because mozilla
crashed (build 2001052606 linux) and i didn't get talkback :(
It's NOT working... Please work on this as this is critical for 0.9.1 as it
worked fine in 0.9
(Assignee)

Comment 20

18 years ago
I tried in 2001052908 and it seems to work just fine.  I crash voluntarily and
sent in the talkback data. Can you try today's build ?


Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 21

18 years ago
This may be funny, but tell me how to crash voluntarily. Builds are starting to
get stable :)

Comment 22

18 years ago
talkback works for me also. Latest I've tried is 2001052509/Linux.

Francisco Leon, run a bugzilla query for bugs with the "crash" keyword and a
"new" status and then take your pick (titles like "this page crashes mozilla"
are good choices).

Comment 23

18 years ago
Talkback should get an entry in the "debug" menu for testing
What do you think about this guys?
(Assignee)

Comment 24

18 years ago
Simple way to force a crash and get talkback windows.

kill -SEGV processid (the top mozilla one).

This should bring up the talkback dialog. But, pl. don't submit this
crash info. 

Comment 25

18 years ago
Did the kill thing, and it worked on 2001052808, so i turned agent on
Now i am waiting for it to legally crash, since yesterday's crash did not
activate talkback
My guess is that talkback is enabling on some types of crashes, so please check
this in order to make sure talkback is going up every time the browser crashes

Updated

10 years ago
Component: Talkback Client → Talkback Client
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.