Explore options of using a custom protocol for sync links

RESOLVED WONTFIX

Status

()

Firefox for Android
Android Sync
RESOLVED WONTFIX
6 years ago
7 months ago

People

(Reporter: Paul [pwd], Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID: 20121104030714

Steps to reproduce:

Currently if a user sets Firefox to be the default for sync, it takes the defaults of HTML links across the system. However a user has both Fennec RTM and Fennec Nightly, it gets rather complicated. I propose a custom protocol "[firefox][channel]://" in order to ensure that each app can have system wide http defaults but still be able to open its own sync pages without interference.
(Reporter)

Updated

6 years ago
OS: All → Android
Hardware: All → ARM
Hi Paul,

To clarify: are you talking about the Send Tab to Device interface?  So this is about making the choice of browser more configurable when you receive a notification containing a tab.
(Reporter)

Comment 2

6 years ago
Yep. Basically when you send a tab to an Android device, it'll ask you to pick a program to open the tab with. However if you select to make a program the default, it'll assume you want said program to open all HTML links by default.
If we send a link "http://www.youtube.com/…", Android will offer the YouTube app as a handler.

The same for Google Maps.

We can't simply sniff "http:" and replace it with some app-specific prefix, or dispatch the URI straight to the appropriate Firefox (the Androidy way of doing the same thing), because it would break that ability to integrate with system handlers.

I think we can fairly safely assume that if a user tries to open a web page, and they ask for it to be opened in Firefox, and they ask for that to be the default, that they're OK with Firefox being their default browser. If they want to do something else, they can do so.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

5 years ago
Component: Android Sync → Android Sync
Product: Mozilla Services → Android Background Services

Updated

7 months ago
Product: Android Background Services → Firefox for Android
You need to log in before you can comment on or make changes to this bug.