Closed Bug 808570 Opened 12 years ago Closed 11 years ago

[Fx17] Implement new 'social' download landing page

Categories

(www.mozilla.org :: Pages & Content, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: lforrest, Assigned: sgarrity)

References

Details

(Whiteboard: u=user c=SociaAPI p=)

Will file another bug to explore including the "Facepile" option for this page.
Depends on: 808574
No longer depends on: 797081
Depends on: 808584
We'll need this page in the following locales: en-US, pt-BR, ml, es_ES, es_AR and es_MX

Thanks!
Locale: ach / Acholi
what will this page be for? When is it needed? Also, why do you need this page in Malayalam?
Locale: ach / Acholi
Whiteboard: u=user c=SociaAPI p=
Laura: What specific page is this? We are confused about the purpose of this bug vs. the Facebook tab.
Assignee: malexis → steven
I don't see a design bug for this page - is it underway?
(In reply to Pascal Chevrel:pascalc from comment #3)
> what will this page be for? When is it needed? Also, why do you need this
> page in Malayalam?

It should actually be ID, not ML. 


Design is happening in this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=808584
making small changes to the hero image - please hold on implementation till that's final - unless it won't affect your work.  just fyi.  will be uploaded in the next few hours - asap.
Here is the PSD for FFx 17 users:  
https://www.dropbox.com/s/0ti4qukvi0dikyg/SocialAPI_DownloadFirefoxLanding_fx17users.psd.zip

COPY:
Facebook Messenger for Firefox

• Chat while you browse

• See new updates instantly 

• Make browsing more social

[BUTTON COPY:] Visit Facebook to turn it on »


Copy for alternate state of this page for Firefox 17 users (all copy stays the same except the button copy and we'll remove the line below the button):

Facebook Messenger for Firefox

• Chat while you browse

• See new updates instantly 

• Make browsing more social

[BUTTON COPY:] Get started with Facebook Messenger »
Hi there, It was my understanding that we are not moving forward with the version that's for Fx 17th users - we'd like to have this in our back pockets but if it's a huge burden on webdev I don't think it's a priority - lets discuss today to make sure we're aligned.
(In reply to Tara (musingt) from comment #9)
> Hi there, It was my understanding that we are not moving forward with the
> version that's for Fx 17th users - we'd like to have this in our back
> pockets but if it's a huge burden on webdev I don't think it's a priority -
> lets discuss today to make sure we're aligned.

Correct. That means that we do not need version #1 in Mike's Comment 8, just that second version for users NOT YET on Firefox 17. 

That's this:

"Copy for alternate state of this page for Firefox 17 users (all copy stays the same except the button copy and we'll remove the line below the button):

Facebook Messenger for Firefox

• Chat while you browse

• See new updates instantly 

• Make browsing more social

[BUTTON COPY:] Get started with Facebook Messenger »"
Consider adding the browser sniffing functionality to this page. Hero image for various operating systems are being created in Bug 806636.
I have a basic start on this page based on the assumption that it will live at mozilla.org/firefox/social/

How will traffic be directed to this page?
(In reply to Steven Garrity from comment #12)
> I have a basic start on this page based on the assumption that it will live
> at mozilla.org/firefox/social/
 
For SEO mojo Let's call it:
mozilla.org/firefox/facebookmessenger

> How will traffic be directed to this page?

A large majority of Firefox users who are not on the most recent version of Firefox will need to upgrade first, in order to start using the Messenger. That said, we need to provide a smooth upgrade flow for them. We will do some version sniffing, and those people not on Firefox 17 or above will get directed to this page to upgrade. 

The main source of traffic will be from Facebook's main landing page here: https://www.facebook.com/about/messenger-for-firefox

That button has a state that says something like "if you're not on the most recent version go here before using this feature"
(In reply to Laura Forrest from comment #13)
> For SEO mojo Let's call it:
> mozilla.org/firefox/facebookmessenger

Sure.

> A large majority of Firefox users who are not on the most recent version of
> Firefox will need to upgrade first, in order to start using the Messenger.
> That said, we need to provide a smooth upgrade flow for them. We will do
> some version sniffing, and those people not on Firefox 17 or above will get
> directed to this page to upgrade. 

The version sniffing you mention - where should that happen?

We currently do the fx/not-fx detection on mozilla.org/firefox, and send visitors to either /firefox/fx/ or /firefox/new/. Then, on /firefox/fx/ we should different content under the Desktop tab depending on whether the visitor has the latest version of Firefox.

Are all visitors looking for Firefox (/firefox, /firefox/fx, /firefox/new) to see this new page? We'll have to work out the details of this browser detection/redirection carefully, as it's a key part of the download path on mozilla.org. Thanks.
No redirects needed, but thanks for checking! 

Final creative is explained here: https://bugzilla.mozilla.org/show_bug.cgi?id=808584#c17
This page is built out in a git branch (https://github.com/mozilla/bedrock/tree/bug-808570-social-landing) and is now just waiting on the updated platform-specific hero images.
This can be previewed and checked out by QA at https://www-demo3.allizom.org/b/en-US/firefox/facebookmessenger/

As far as I know, this page is done - but there maybe a mac version of the screenshot coming. It's getting pretty late for that though.
OS: Mac OS X → All
Hardware: x86 → All
Steven, could you enclose the page title in a l10n call please, like:
{% block page_title %}{{ _('Free Download') }}{% endblock %}

Thanks
(In reply to Pascal Chevrel:pascalc from comment #18)
> Steven, could you enclose the page title in a l10n call please, like:
> {% block page_title %}{{ _('Free Download') }}{% endblock %}

Replaced that page title with the same text as the headline, and wrapped for l10n.
Laura: Our download button is not ready to be localised at the moment. This is part of my tasks to work on before the end of November but for now, it is not possible. I'll try to have something for Tuesday but this is not guaranteed as I need to look at the code before knowing how much needs to be done.
Pull req
(In reply to Anthony Ricaud (:rik) from comment #20)
> Laura: Our download button is not ready to be localised at the moment. This
> is part of my tasks to work on before the end of November but for now, it is
> not possible. I'll try to have something for Tuesday but this is not
> guaranteed as I need to look at the code before knowing how much needs to be
> done.

This is a huge red flag. We have localized download buttons on pages like this: http://www.mozilla.org/fr/firefox/new why is this blocked? Why not use the old platform? I'll setup a call asap to discuss.
(In reply to Laura Forrest from comment #22)
> (In reply to Anthony Ricaud (:rik) from comment #20)
> > Laura: Our download button is not ready to be localised at the moment. This
> > is part of my tasks to work on before the end of November but for now, it is
> > not possible. I'll try to have something for Tuesday but this is not
> > guaranteed as I need to look at the code before knowing how much needs to be
> > done.
> 
> This is a huge red flag. We have localized download buttons on pages like
> this: http://www.mozilla.org/fr/firefox/new why is this blocked? Why not use
> the old platform? I'll setup a call asap to discuss.

Laura: We have never launched a localized page on Bedrock that has a download button. We cannot currently do a download page on Bedrock that is in anything other than en-US. This has always been the case and we should be unblocked by December 2012. This is why I wanted to keep the scope of this project to a minimum and prevent scope creep, because we could easily slide into an area that is currently technically blocked.
Hi there, the hero image on this page has some issues:

* the chrome is blue, but on the magnifying glass the color shifts.
* Ty has an updated PSD for this, perhaps it fell through the cracks int he hand off somewhere, but it has been updated on most assets.  Please update!
* cc-in Ty for PSD support.
If we launch this page on the go-live for the project, can we just do en-US only due to the bedrock button blocker?
(In reply to Chris More [:cmore] from comment #27)
> If we launch this page on the go-live for the project, can we just do en-US
> only due to the bedrock button blocker?

Yes. In the mean-time let's work on fixing that blocker.
For when we can localize the download button, here's the l10n info: 

The files are named:
Hero Graphic 
SocialAPI_Download
FirefoxLanding_fx17users
SocialAPI_DownloadFirefoxLanding


===Localization Files====

I'm unable to attach the file to Bugzilla so am posting links to the files two different ways here. 

1. Dropbox https://dl.dropbox.com/u/76193488/Social_API_translated_21_languages.zip

2. Basecamp: https://basecamp.com/1897137/projects/1351525-social-api/messages/6159899-l10n-update#comment_31803309

I will also email them.
With updated PSD, ready for preview/QA in en-US here: https://www-demo1.allizom.org/b/en-US/firefox/facebookmessenger/
There seems to be an artifact on the magnifying glass - the corner part of the chrome is showing. I don't think that is how the design was intended.  otherwise it looks fine to me.
How are the localized versions of this page coming along? (see comment 30 for translations)

When will they be live? Should we use this bug to track? Please advise.
Depends on: 795976
All: I've made this bug be blocked by bug 795976 since we need the designs for localized buttons to be finalized before doing the technical implementation.
I am integrating the strings you provided into the template Steven prepared, AFAIK, the only blocker is the template for download boxes which needs some tweaks to reuse the strings for download boxes we already have on the php side. This depends on the cleanup work that Anthony is doing in Bug 814079. This was also blocked by our ability to push pages on a locale per locale basis (and not all locales or just en-US), this one was fixed by pmac and pushed to prod today. Updating dependencies on this bug to reflect that.

Note that not all the files provided respect the format we asked and also, since the strings were given to these localizers before Steven could work on the template, there is markup missing (<span> tags) that I need to add manually. For some locales (like rtl locales), we will probably need native speakers to add the markup themselves into the strings to avoid marking up the wrong words.

The demo server linked by Steven in comment #31 is no longer showing the facebookmessenger page, but if you have a local machine with mozilla.org installed locally, I can send your translations to the VCS and you can then see them locally if you switch to the bug-808570-social-landing github branch.
Depends on: 814079, 794059
No longer depends on: 795976
Pascal, can you give me a list of the locales that weren't formatted correctly? (E-mail is fine). The contractor was given explicit instructions about formatting and I'd like to give them feedback on which locales came back wrong. 

Thanks
C
Chelsea, I'll send you the list by email, I am not finished with integrating all the translations yet.
Depends on: 795976
This never ended up being used in production.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.