Status

P3
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: ranbena, Assigned: ranbena)

Tracking

unspecified

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(3 attachments, 1 obsolete attachment)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.60 Safari/537.11

Steps to reproduce:

1. Geolocation prompt
2. Bookmark icon size and apps shadow
3. Font style
4. Home button function
5. Smartfolder feature
6. Offline apps feature
7. Shortcuts edit mode implementation
8. Over scrolling
9. Header and searchbar style
10. Various bug fixes and performance optimisations



Actual results:

1. Still appears in old version. Not using true geolocation position.
2,3. Not the right styling
4. Takes back to landing page instead of expected functionality
5,6,7.  Not up-to-date
8. Has bounce back
9. Not up-to-date
10. Not implemented


Expected results:

1. Should be the OS getCurrentPosition
2. Should be 49x49 and he correct shadow
3. Should be MozTT etc.
4. Should close smartfolder, return from shortcut edit mode etc. without returning to landing page
5. Should be there
6. Should be there
7. Should be implemented with a <select>
8. Should have no bounce back
9. Should be up-to-date
10. Implemented
Assignee: nobody → ran
Please add the patch here and IMHO it's very difficult to review it, there are 46 files changed. Vivien any suggestion? Thanks
blocking-basecamp: --- → ?

Comment 2

6 years ago
a link to the PR from here can also help. 

I agree with Cristian that smaller bugs and simple PRs help reviews.
Created attachment 678367 [details] [diff] [review]
UI fixes and changes
Perhaps I can help the reviewer. Apart for minor changes in apps/homescreen/index.html, it's all Evme files with zero affect on the rest of the system.
I don't have problems to review although I prefer less code. Vivien will decide if there are or not risk with this code on the rest  of the system. IMHO there aren't risk but I am only a reviewer here :) Tomorrow I can start on reviewing friend
Cool. I'll get some comments into the pull request as well to make it easier to understand.
blocking-basecamp: ? → +
Priority: -- → P3
Created attachment 679076 [details] [diff] [review]
UI fixes and changes
Attachment #678367 - Attachment is obsolete: true
Created attachment 679112 [details] [diff] [review]
Code changes due to PR comments
Created attachment 679145 [details] [diff] [review]
More code changes due to PR comments
Attachment #679145 - Flags: review?(crdlc)
Attachment #679145 - Flags: review?(crdlc) → review+
r+ and blocking-basecamp+ landing
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Duplicate of this bug: 805990
(Assignee)

Updated

6 years ago
Duplicate of this bug: 798705
(Assignee)

Updated

6 years ago
Duplicate of this bug: 805997
(Assignee)

Updated

6 years ago
Duplicate of this bug: 798713

Comment 16

6 years ago
Verified on Unagi device Build ID: 20130112070202
v1.o
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.