CSS border arrows appear like blurred rectangles

RESOLVED DUPLICATE of bug 804747

Status

()

RESOLVED DUPLICATE of bug 804747
6 years ago
6 years ago

People

(Reporter: tvkanters, Unassigned)

Tracking

16 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

Create an arrow using CSS borders.
E.g.,
.arrow-down{
 position: absolute;
 right: 5px;
 top: 10px;
 width: 0;
 height: 0;
 border-left: 5px solid transparent;
 border-right: 5px solid transparent;
 border-top: 5px solid #E9E9E9;
}



Actual results:

Since branch 14 or near the arrow, while rendered correctly in Chrome and Internet Explorer, appeared like a blurred rectangle.
Popular products such as Gmail and Facebook also suffer from this issue. For example: http://clicpharmacodebits.files.wordpress.com/2012/07/capture5.png?w=551


Expected results:

The arrow should not contain any blur, nor rectangle shape.
See http://blog.clicdata.com/2012/07/19/why-the-hell-my-css-arrow-is-blurry-on-firefox-14-0-1/ for an additional description.

It is worth noting that not every installation of Firefox has this issue. My work computer renders arrows correctly, but two computers at home have arrows blurred.

Comment 1

6 years ago
This sounds similar to what was reported in bug 804747. Does disabling hardware acceleration in Tools > Options > Advanced > General fix it?
(Reporter)

Comment 2

6 years ago
It seems it does. Cheers.
I'll close this one as a duplicate.

In case the info is useful though, below are my graphics specs. Seems like the other guy has the same videocard.

Adapter Description
NVIDIA GeForce GTX 670

Vendor 
ID0x10de

Device
ID0x1189

Adapter RAM
2048

Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um

Driver Version
9.18.13.602

Driver Date
8-22-2012

Direct2D Enabled
false

DirectWrite Enabled
false (6.1.7601.17789)

ClearType Parameters
ClearType parameters not found

WebGL Renderer
Google Inc. -- ANGLE (NVIDIA GeForce GTX 670) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)

GPU Accelerated Windows
0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 804747
You need to log in before you can comment on or make changes to this bug.