Status

()

--
critical
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: marc.loiselle, Assigned: law)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Steps to reproduce.

Visit http://en.carpoint.msn.ca/vip/Overview/Porsche/911/New.asp
Right click the Porsche image.
Select "Save Image ( )..."
Change the file name.
Click Save button.
Crash.  Download dialog does not appear and file is not created.

No crash if the filename is not changed.

Buildid 2001051421

BTW how can I generate a backtrace when there is no core.  ./mozilla -g then run
just displays "ptrace: no such process".

Comment 1

18 years ago
hmmm, strabnge behaviour on this one.
I am debugging with "ddd", not much more then a GUI for gdb. between clicking at
"save picture ()" and the appearance of the "where to save" window, i get the
following message:
"the mouse pointer appears to be frozes. continuing execution automaticly, which
reappears after clicking on "save".
my debugger also tells me the following: 
Document http://en.carpoint.msn.ca/vip/Overview/Porsche/911/New.asp loaded
successfully
warning: find_solib: Can't read pathname for load map: Eingabe-/Ausgabefehler

Cannot access memory at address 0x21.
(gdb) cont
Continuing.

I did not type the "cont" myself.
I see no crash and the picture is saved and does work.
Funny is the filename of this file: merismus\\Gallery\\c438763a.jpg
the folder structure  got saved within the filename. this seems to be a problem
of the webpage, since NS4.x does it similar (except it replaces the \\ with _). 

ok, i am not sure, how mozilla can survive the "Cannot access memory at
address0x21", but here Mozilla does NOT crash, also not without debugger. So I
would give it a WorksForMe.
I am using 2001051508 for Linux on a Suse6.4 system.

> BTW how can I generate a backtrace when there is no core.  ./mozilla -g then 
> run just displays "ptrace: no such process".

This depends on the GDB and the libs you have. at work I use the ancient
Suse6.4, where debugging works (gdb4.x) while at home with a quite recent
Suse7.1 I see the same message. 
There is bug 57051 about this (blocker, Moz 0.9.1), which you should read. 


Comment 2

18 years ago
Eingabe-/Ausgabefehler = I/O-error.


(Reporter)

Comment 3

18 years ago
Jens-Uwe: did you try changing the filename before clicking Save.  That is what 
causes the crash for me.  

Interesting that the suggested filename on Windows is c438763a.jpg while it is 
merismus\Gallery\c438763a.jpg on Linux.

Comment 4

18 years ago
ok, you got me. just another crasher in  NSGetModule. I tried to call the file
c438763a.jpg and can reproduce the crash reliable with 2001051508 for linux.


below the stack trace:

Program received signal SIGSEGV, Segmentation fault.
0x0 in ?? ()
(gdb) where
#0  0x0 in ?? ()
#1  0x40eaf6f5 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#2  0x40eafaf1 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#3  0x40eaece4 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#4  0x40eae446 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#5  0x40dec637 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#6  0x40e309be in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#7  0x41009bb0 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libeditor.so
#8  0x40abb9fb in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgkcontent.so
#9  0x40c16eba in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgkcontent.so
#10 0x40af4e57 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgkcontent.so
#11 0x40abe60c in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgkcontent.so
#12 0x40df1467 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#13 0x40df133c in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgklayout.so
#14 0x40f2781a in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgkview.so
#15 0x40f30f0e in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgkview.so
#16 0x40f271ad in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libgkview.so
#17 0x40499dea in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#18 0x40499d15 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#19 0x40499d8a in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#20 0x4049d92c in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#21 0x4049d881 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#22 0x409495cf in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libjsdom.so
#23 0x4046fc47 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libnsappshell.so
#24 0x40499dea in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#25 0x40499d15 in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#26 0x40499d8a in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#27 0x4049d92c in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#28 0x4049dabd in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#29 0x4049fe3c in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#30 0x4055c6ff in gtk_marshal_BOOL__POINTER () at gtkmarshal.c:124
#31 0x4058d948 in gtk_handlers_run (handlers=0x816fed0, signal=0xbfffe884,
object=0x875e528, params=0xbfffe8d8, after=0) at gtksignal.c:1909
#32 0x4058cd1f in gtk_signal_real_emit (object=0x875e528, signal_id=31,
params=0xbfffe8d8) at gtksignal.c:1469
#33 0x4058acc7 in gtk_signal_emit () at gtksignal.c:234
#34 0x405c352c in gtk_widget_event () at gtkwidget.c:2707
#35 0x405cbcac in gtk_window_focus_in_event (widget=0x875e958, event=0x826e6fc)
at gtkwindow.c:1333
#36 0x4055c6ff in gtk_marshal_BOOL__POINTER () at gtkmarshal.c:124
#37 0x4058cd5d in gtk_signal_real_emit (object=0x875e958, signal_id=31,
params=0xbfffec98) at gtksignal.c:1484
#38 0x4058acc7 in gtk_signal_emit () at gtksignal.c:234
#39 0x405c352c in gtk_widget_event () at gtkwidget.c:2707
#40 0x4055b7eb in gtk_main_do_event () at gtkmain.c:807
#41 0x40494d4f in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#42 0x4060d9c4 in gdk_event_dispatch (source_data=0x0, current_time=0xbffff0ec,
user_data=0x0) at gdkevents.c:2129
#43 0x4063bbd6 in g_main_dispatch (dispatch_time=0xbffff0ec) at gmain.c:656
#44 0x4063c203 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#45 0x4063c3cc in g_main_run () at gmain.c:884
#46 0x4055b00c in gtk_main () at gtkmain.c:807
#47 0x4048cfdc in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libwidget_gtk.so
#48 0x4046dcea in NSGetModule () from
/home/jur/ftp/test/mozilla/components/libnsappshell.so
#49 0x804d1c4 in StringAllocator_char ()
#50 0x804da15 in StringAllocator_char ()
#51 0x401e9a5e in __libc_start_main () at ../sysdeps/generic/libc-start.c:93

Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

18 years ago
-->Bill
Assignee: neeti → law
(Assignee)

Comment 6

18 years ago
I'd bet dollars to donuts this has nothing to do with any xpapps code.  My tough
luck you happened upon this whild saving the file, I guess.
(Reporter)

Comment 7

18 years ago
wfm with cvs build from 20010520.

Comment 8

18 years ago
mass move, v2.
qa to me.
QA Contact: tever → benc
(Reporter)

Comment 9

18 years ago
resolving to worksforme
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 10

18 years ago
+crash, verifyme
VERIFIED:
WFM in Mozilla 0.9.2, Win98.
Since this is a crasher, I need to verify on all plats before I OK this....

Does necko to the file i/o when saving?

Keywords: crash, verifyme

Comment 11

18 years ago
verified wfm linux 2001071021.
benjamin: this bug was reported on linux, does it still have to be tested on all
plattforms?

Comment 12

18 years ago
If verification is left to me, that is the standard of testing I will use.

If someone else thinks it is good, they can mark it verified.
(Reporter)

Comment 13

18 years ago
verified wfm
Status: RESOLVED → VERIFIED

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.