implement google analytics on bugzilla.mozilla.org

RESOLVED FIXED

Status

Websites
Web Analytics
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: glob, Assigned: cmore)

Tracking

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

6 years ago
> Full website address

https://bugzilla.mozilla.org/

> Explain the goal and use-case of having web analytics on this website.

currently use webtrends to track visitor counts and capabilities.
keen to move away from it :)

> Do you have requirements to track user interactions on your website?

no

> Define the people who should have access to the reports.

glob@mozilla.com
dkl@mozilla.com
mcote@mozilla.com
(Assignee)

Comment 1

6 years ago
Here are the instructions for implementing Google Analytics on our website.

For more information, see http://code.google.com/apis/analytics/docs/tracking/asyncTracking.html

Copy the following code, then paste it onto every page you want to track immediately before the closing </head>tag.


<script type="text/javascript">

  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-36116321-3']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>
Assignee: nobody → chrismore.bugzilla
Status: NEW → ASSIGNED
(Assignee)

Comment 2

6 years ago
Google has been emailed to enable premium.
Created attachment 679314 [details] [diff] [review]
Patch to add jscript snippet to header for analytics (v1)

Also removes current webtrends code as I assume we will no longer be using that once we transition to google.
Attachment #679314 - Flags: review?(glob)
(Assignee)

Comment 4

6 years ago
dkl@mozilla.com is not a registered google email.
(Assignee)

Comment 5

6 years ago
blog and mcote have been added.
(Reporter)

Updated

6 years ago
Blocks: 809747
(Reporter)

Comment 6

6 years ago
Comment on attachment 679314 [details] [diff] [review]
Patch to add jscript snippet to header for analytics (v1)

i've moved this patch to bug 809747 so we can track the code changes separately from the google config changes.
Attachment #679314 - Attachment is obsolete: true
Attachment #679314 - Flags: review?(glob)
(Reporter)

Comment 7

6 years ago
(In reply to Chris More [:cmore] from comment #5)
> blog and mcote have been added.

heh :)

i can confirm that i have access to the data -- one visitor, from NC, wonder who that was ;)
(In reply to Chris More [:cmore] from comment #4)
> dkl@mozilla.com is not a registered google email.

I have dkl@mozilla.com now linked to my dklawren@gmail.com account which you can use if you like. My corporate gmail account is dlawrence@mozilla.com.

Thanks
dkl
(Assignee)

Comment 9

6 years ago
(In reply to David Lawrence [:dkl] from comment #8)
> (In reply to Chris More [:cmore] from comment #4)
> > dkl@mozilla.com is not a registered google email.
> 
> I have dkl@mozilla.com now linked to my dklawren@gmail.com account which you
> can use if you like. My corporate gmail account is dlawrence@mozilla.com.
> 
> Thanks
> dkl

dkl@mozilla.com added!

This account should be enabled for premium by Friday.
(Reporter)

Comment 10

6 years ago
all appears to be working (dkl has access to the data now).
you can probably close this bug if there's nothing else you need to do.

thanks for your help.. so much new data and graphs to wade through :)
(Assignee)

Comment 11

6 years ago
GA enabled for premium on 11/9/2012. Love that this is being used to quickly!
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

5 years ago
:glob: Can I remove your auglob@g****.com and add your bjones@mozilla.com email? We are standardizing all access to Mozilla Google Apps accounts which are tied to LDAP. Thanks!
(Reporter)

Comment 13

5 years ago
(In reply to Chris More [:cmore] from comment #12)
> :glob: Can I remove your auglob@g****.com and add your bjones@mozilla.com
> email? We are standardizing all access to Mozilla Google Apps accounts which
> are tied to LDAP. Thanks!

that would be quite problematic for me, as it appears i can't be signed into GA as bjones@mozilla.com without first logging out of all my other google resources, and GA doesn't support multiple sign-in.

glob@mozilla.com is tied with my ldap account via the bugzillaEmail ldap attribute, or can you only use the cn?
(Assignee)

Comment 14

5 years ago
(In reply to Byron Jones ‹:glob› from comment #13)
> (In reply to Chris More [:cmore] from comment #12)
> > :glob: Can I remove your auglob@g****.com and add your bjones@mozilla.com
> > email? We are standardizing all access to Mozilla Google Apps accounts which
> > are tied to LDAP. Thanks!
> 
> that would be quite problematic for me, as it appears i can't be signed into
> GA as bjones@mozilla.com without first logging out of all my other google
> resources, and GA doesn't support multiple sign-in.
> 
> glob@mozilla.com is tied with my ldap account via the bugzillaEmail ldap
> attribute, or can you only use the cn?

Hmmm, within Firefox, I can log into any of my Google accounts with different services with different email addresses. For example, I can log into chrismore.bugzilla and cmore@mozilla.com differently between GA and Google Docs.

Let me try glob@mozilla.com and see if it allows me to add it.
(Assignee)

Comment 15

5 years ago
I can't add glob@mozilla.com. It must be tied to your gmail.com account. Have you separated your gmail and @mozilla.com emails so that you can log into them separately?
(Reporter)

Comment 16

5 years ago
i do have two google accounts -- one with most of my addresses linked, including glob@mozilla.  the other is bjones@mozilla, which is the mozilla apps one, which i don't really use.

when i'm signed in to a google service with my primary google account, i'm automatically authenticated to GA as that account -- i'm not presented with the opportunity to log in as a different user.  signing out of GA signs me out across all my tabs, not just GA.

on some services i can sign in multiple times with different accounts, however GA doesn't support multiple-sign -- see http://support.google.com/accounts/bin/answer.py?hl=en&answer=1721977

> I can't add glob@mozilla.com.

probably because glob@mozilla.com is linked with what you're seeing as auglob@, and already has access.

> Have you separated your gmail and @mozilla.com emails so that you can log into them
> separately?

sorry, but i don't know what you're asking here.
(Assignee)

Comment 17

5 years ago
(In reply to Byron Jones ‹:glob› from comment #16)
> i do have two google accounts -- one with most of my addresses linked,
> including glob@mozilla.  the other is bjones@mozilla, which is the mozilla
> apps one, which i don't really use.
> 
> when i'm signed in to a google service with my primary google account, i'm
> automatically authenticated to GA as that account -- i'm not presented with
> the opportunity to log in as a different user.  signing out of GA signs me
> out across all my tabs, not just GA.
> 
> on some services i can sign in multiple times with different accounts,
> however GA doesn't support multiple-sign -- see
> http://support.google.com/accounts/bin/answer.py?hl=en&answer=1721977
> 
> > I can't add glob@mozilla.com.
> 
> probably because glob@mozilla.com is linked with what you're seeing as
> auglob@, and already has access.
> 
> > Have you separated your gmail and @mozilla.com emails so that you can log into them
> > separately?
> 
> sorry, but i don't know what you're asking here.

I mean, what is preventing you from logging in to GA with bjones@mozilla.com to view GA? I know GA doesn't handle multiple log ins, but you should be able to log out of the gmail account and into the @mozilla.com one if you un-link (remove as secondary email) the two accounts. That's what I did when I first had chrismore.bugzilla and cmore@mozilla.com link together. They are separate accounts.
(Reporter)

Comment 18

5 years ago
i had a quick chat with cmore via irc.

the order which you sign-in is important.  i had to sign-in to GA as bjones (which dropped my other sessions), then sign-in in with my normal account on other tabs.

sorry about not getting that earlier.
You need to log in before you can comment on or make changes to this bug.