Flash fullscreen is broken on Aurora

RESOLVED WORKSFORME

Status

()

Firefox for Android
Plugins
--
major
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: xti, Assigned: snorp)

Tracking

18 Branch
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox17 unaffected, firefox18+ verified, firefox19 unaffected)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 678700 [details]
screenshot

Firefox 18.0a2 (2012-11-05)
Device: Galaxy S2
OS: Android 4.0.3

Steps to reproduce:
1. Go to youtube.com (desktop site)
2. Tap on any video from the list
3. After the page for selected video is fully loaded, tap on the video side to enable the flash plug in
4. Tap on Full Screen button from the bottom-left side of the video

Expected result:
The video switches to full screen mode and continues to play.

Actual result:
The video switches to full screen mode but the entire app will freeze. Also the entire OS will freeze for a couple of seconds. Please see the attached image to see what happens after device Home button starts to work again (it will persist for almost a minute on the Android desktop screens)
Also I attached the logs of this issue.


Notes:

A. The Aurora process hardly can be killed, and even when it does, reopening the app again, I can still see the same bad state as it was before. The app cannot be used again until its data will be cleared.

B. I cannot reproduce this issue on Nightly or Beta build. It might be a regression from bug 801627
(Reporter)

Comment 1

5 years ago
Created attachment 678701 [details]
logs

This log section is just after I tapped the fullscreen button: 

D/GeckoLayerClient(11604): Window-size changed to (800,480)
I/GeckoPlugins(11604): void anp_event_postEvent(NPP_t*, const ANPEvent*)
I/GeckoPlugins(11604): returning from void anp_event_postEvent(NPP_t*, const ANPEvent*)
I/SurfaceFlinger( 1816): id=564(14) createSurface 0x2ff9c (800x480),1 flag=0
I/SurfaceFlinger( 1816): id=565(164) createSurface (1600x480),-1 flag=20000
I/SurfaceFlinger( 1816): id=566(165) createSurface (800x960),-1 flag=20000
I/SurfaceFlinger( 1816): id=567(166) createSurface (1600x480),-1 flag=20000
I/SurfaceFlinger( 1816): id=568(167) createSurface (800x960),-1 flag=20000
I/SurfaceFlinger( 1816): id=569(15) createSurface 0x38484 (800x480),842094169 flag=400
I/AudioPolicyManager( 1819): stopOutput() output 1, stream 3, session 260
W/SurfaceTexture(11604): freeAllBuffersExceptCurrentLocked called but mQueue is not empty
D/gralloc (11604): unmmap  pid(1816), vaddr(0x66e1c000)
E/gralloc (11604): [GR_MD] unmapping from 0x66c00000, size=33427456
D/gralloc (11604): unmmap  pid(1816), vaddr(0x68eda000)
E/gralloc (11604): [GR_MD] unmapping from 0x68c64000, size=33427456
D/gralloc (11604): unmmap  pid(1816), vaddr(0x6af86000)
E/gralloc (11604): [GR_MD] unmapping from 0x6acb6000, size=33427456
D/gralloc (11604): unmmap  pid(1816), vaddr(0x72320000)
E/gralloc (11604): [GR_MD] unmapping from 0x71f9c000, size=33427456
E/SurfaceTexture(11604): [unnamed-11604-4] cancelBuffer: slot 4 is not owned by the client (state=0)
E/SurfaceTexture(11604): [unnamed-11604-4] cancelBuffer: slot 2 is not owned by the client (state=0)
E/SurfaceTexture(11604): [unnamed-11604-4] cancelBuffer: slot 1 is not owned by the client (state=0)
E/SurfaceTexture(11604): [unnamed-11604-4] cancelBuffer: slot 0 is not owned by the client (state=0)
D/gralloc ( 1819): unmmap  pid(1816), vaddr(0x4f8d0000)
E/gralloc ( 1819): [GR_MD] unmapping from 0x4f4f2000, size=33427456
D/gralloc ( 1819): unmmap  pid(1816), vaddr(0x4d895000)
E/gralloc ( 1819): [GR_MD] unmapping from 0x4d511000, size=33427456
D/gralloc ( 1819): unmmap  pid(1816), vaddr(0x4b797000)
E/gralloc ( 1819): [GR_MD] unmapping from 0x4b46d000, size=33427456
D/gralloc ( 1819): unmmap  pid(1816), vaddr(0x496e1000)
E/gralloc ( 1819): [GR_MD] unmapping from 0x49411000, size=33427456
D/gralloc ( 1819): unmmap  pid(1816), vaddr(0x475bd000)
E/gralloc ( 1819): [GR_MD] unmapping from 0x47347000, size=33427456
D/gralloc ( 1819): unmmap  pid(1816), vaddr(0x4555e000)
E/gralloc ( 1819): [GR_MD] unmapping from 0x45342000, size=33427456
W/ALooperRoster( 1819): failed to deliver message. Target handler 119 registered, but object gone.
I/AudioFlinger( 1819): stop output streamType (0, 3) for 1
I/GeckoPlugins(11604): Initialized? 1
E/GeckoPlugins(11604): !!!!!!!!!!!!!!  void anp_window_setVisibleRects(NPP_t*, const ANPRectI*, int32_t) not implemented ../../../../../dom/plugins/base/android/ANPWindow.cpp, 27
D/PowerManagerService( 1975): releaseWakeLockLocked flags=0x0 tag=nsNPAPIPluginInstance myUID=1000 myPID=1975 myTID=2221
D/VideoSurfaceView(11604): Changing FP Instance from 0 to 1555475136
D/gralloc (11604): unmmap  pid(1816), vaddr(0x6d098000)
E/gralloc (11604): [GR_MD] unmapping from 0x6cd6e000, size=33427456
Can you get a regression-range, by checking to see if prior to  bug 801627 landing on Oct 26 makes a difference?

What is missing from Aurora here?
Keywords: regressionwindow-wanted

Updated

5 years ago
Component: Graphics, Panning and Zooming → Plugins

Updated

5 years ago
Assignee: nobody → snorp
(Reporter)

Comment 3

5 years ago
(In reply to Aaron Train [:aaronmt] from comment #2)
> Can you get a regression-range, by checking to see if prior to  bug 801627
> landing on Oct 26 makes a difference?

On the build from 10/26, the only reproducible issue was the one from bug 801627, where just the sound was working, but no hangs or app freezes occured. This issue is reproducible since 10/27 when bug 801627 has landed on the Aurora channel.

Updated

5 years ago
Blocks: 801627

Updated

5 years ago
tracking-fennec: --- → ?
We need bug 797942 backed out from Aurora.
Depends on: 797942

Updated

5 years ago
tracking-firefox18: --- → +
fixed by backout
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
tracking-fennec: ? → ---
Adding qawanted,verifyme to confirm this was fixed.
status-firefox18: affected → fixed
Keywords: qawanted, verifyme
(Reporter)

Comment 8

5 years ago
I cannot reproduce this issue on the latest Aurora build. It seems that the backout of bug 801627 has fixed this. 

If I move the app to background while the video is playing in full screen mode and then reopen it back, I am able just to zoom in/out the page. Reload, back and Menu are not working at all. If I go to Awesomescreen, the app will freeze. This behavior is similar to bug 809055.

--
Firefox 18.0a2 (2012-11-12)
Device: Galaxy S2
OS: Android 4.0.3
status-firefox18: fixed → verified
Keywords: qawanted, verifyme
You need to log in before you can comment on or make changes to this bug.