If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Better object introspection in object popup

RESOLVED FIXED

Status

()

Firefox
Developer Tools: Console
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: David Bruant, Unassigned)

Tracking

18 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
Currently, in object popups of the WebConsole (thing that appear when you click on a logged object), only own properties can be seen.
It would be nice at least to provide a link to visualize the [[Prototype]] of the object. The object popup could also show other informations provided by the debugger API https://developer.mozilla.org/en-US/docs/SpiderMonkey/JS_Debugger_API_Reference/Debugger.Object (class, whether it's a proxy...)
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 794823
This may not be entirely a dupe. Bug 794823 was all about providing the extra functionality, but we now need to fix bug 808370 - Use the VariablesView in webconsole.

Mihai, what do you think?
Agreed with Victor. We need bug 808370 then we can re-evaluate this bug.

Thank you David for the bug report.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
This bug should be fixed by bug 808370. We now show an object's own properties and the prototype chain can be inspected with the variables view.

Please reopen if you believe otherwise.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.