Status

()

Firefox
General
RESOLVED DUPLICATE of bug 719484
6 years ago
6 years ago

People

(Reporter: gps, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
We don't yet have a bug to track implementing about:metrics (dashboard for Firefox Health Report). This will be that bug.
(Reporter)

Comment 1

6 years ago
Created attachment 678789 [details] [diff] [review]
Implement about:metrics for browser, v1

This is the latest code I have. I haven't really looked at it in much detail. These patches were effectively lifted from elsewhere. I'm not sure who wrote this code. The code is untested and probably broken.

Anyway, the idea is that about:metrics contains a dashboard for visualizing data sent as part of FHR. There is a local part to the page and a remote part. The remote part is where all the visualization code lives. Trevor is doing the remote part. I think the main reason the visualization code doesn't live in the browser itself is because of the size. I think they are pulling down largish JS assets that would bloat the browser package.

We are still awaiting final UX designs for this page. I figured I'd get the current code up and tracked somewhere.
(Reporter)

Comment 2

6 years ago
Doh.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 719484
You need to log in before you can comment on or make changes to this bug.