[xpcdom?] Webcal entries won't submit

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: John Hayward-Warburton, Assigned: jst)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Webcal v3.03 diary entries no longer submit. It appears there are two issues.

(1) The Javascript dassumes "form1.submit()" will work instead of
"document.forms.form1.submit()" -- I get a "form1 is not defined" error. Editing
the code gets rid of this.

(2) Something else is wrong. This:

<input TYPE="button" VALUE="submit"
ONCLICK="window.opener.name='WebCal';document.forms.form1.target=window.opener.name;document.forms.form1.submit()">

does not result in the "WebCal" window receiving the form and updating itself.

The trouble is, this DID work on Mozilla nightlies until about a fortnight ago.

A test page is
http://bulldog.tzo.org/perl/webcal.cgi?function=webday&date=20010511&cal=public

Add a calendar entry and see what happens.
not engine
Assignee: rogerl → jst
Component: Javascript Engine → DOM Level 0
QA Contact: pschwartau → desale
Summary: Webcal entries won't submit → [xpcdom?] Webcal entries won't submit
(Assignee)

Comment 2

17 years ago
Is this still a problem, or was it due to the form submission problems caused by
the HTTP changes?
(Reporter)

Comment 3

17 years ago
Amazing. Now works on CVS pulled at 0300 UTC today, 16th May.
(Assignee)

Comment 4

17 years ago
Worksforme then.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → REMIND

Comment 5

17 years ago
Reopening to mark it worksforme instead of remind
Status: RESOLVED → UNCONFIRMED
Resolution: REMIND → ---

Comment 6

17 years ago
worksforme
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

17 years ago
Oh, oops.
You need to log in before you can comment on or make changes to this bug.