Awesomescreen filtering doesn't work if it's initiated from the bookmark or history screens

VERIFIED FIXED in B2G C2 (20nov-10dec)

Status

Firefox OS
Gaia::Browser
P2
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: MattN, Assigned: michalbe)

Tracking

({b2g-testdriver})

unspecified
B2G C2 (20nov-10dec)
b2g-testdriver

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

Typing in the addressbar/searchbox from the history or bookmarks screen doesn't filter or highlight results like it does from "Top Sites".

Having the search box not work like the Top Sites tab makes for a confusing experience which led me to file bug 808917 and bug 808916 for separate filtering support.
This is by design and is consistent with Firefox Mobile.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(In reply to Ben Francis [:benfrancis] from comment #1)
> This is by design and is consistent with Firefox Mobile.

Actually, it does show a filtered awesomescreen on Firefox Mobile and the design[1]
simply says:

"When the user begins typing, the highlighted text is cleared and the Top Sites/Bookmarks/History tabs disappear. As he types, a list of relevant results filtered by frecency is displayed."

[1] https://www.dropbox.com/sh/ygwfxk6chpshxdj/wj9SyPP909/Apps/Browser/R1_AwesomeScreen_v4.pdf (Page 2)
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Oh sorry, I misunderstood your bug report. I thought this was somehow a meta bug of the other two.

Yes, you should get the same awesomescreen results regardless of which tab you start typing from (Top Sites, Bookmarks or History).

I think this may be a regression.
blocking-basecamp: --- → ?
OS: Gonk (Firefox OS) → All
blocking-basecamp: ? → +
Priority: -- → P2
Assignee: nobody → mbudzynski

Comment 4

5 years ago
Milestoning for C2 (deadline of 12/10), as this meets the criteria of "known P2 bugs found before or during C1".
Target Milestone: --- → B2G C2 (20nov-10dec)
(Assignee)

Comment 5

5 years ago
Created attachment 682020 [details]
patch
(In reply to Michal Budzynski (:michalbe) from comment #5)
> Created attachment 682020 [details]
> patch

Michal do you meant to ask review to someone?
Attachment #682020 - Flags: review?(ben)
Comment on attachment 682020 [details]
patch

Ben told me you need some changes to this code. So carrying r-.
Attachment #682020 - Flags: review?(ben) → review-
(Assignee)

Updated

5 years ago
Attachment #682020 - Flags: review- → review?(ben)
Comment on attachment 682020 [details]
patch

r+me with the completed revisions.
Attachment #682020 - Flags: review?(ben) → review+
https://github.com/mozilla-b2g/gaia/commit/243eaf090186e90c296472c80795191d3d688136
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 814610
Thanks everyone.  I verified the fix on the stable update channel for b2gtd.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.