[debugger] High CPU usage when breakpoint reached

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Debugger
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: paul, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
STR:
- load http://htmlpad.org/debugger.html/
- breakpoint on test
- Firefox CPU usage around ~3%
- click "click me"
- CPU usage slowly (10s) reaches 50%
- once not paused anymore (after clicking on resume), CPU usage comes back to normal
Try using the profiler to get some insight into what is happening in that CPU spike. Also, is this on a debug or optimized build?
(Reporter)

Comment 2

5 years ago
Hope that helps (profile): http://is.gd/jJes0w
Unfortunately that profile doesn't tell the whole story. We're missing ~83% of the running time of sites called by TA_nest. Perhaps it's OS-specific code that we don't get profiling samples for?
(In reply to Panos Astithas [:past] from comment #3)
> Perhaps it's OS-specific code that we don't get profiling samples for?

The lack of stack unwinding for native code certainly doesn't help. I'll try with perf after I unbreak my local builds and reboot with a kernel for which i do have perf.
So, this is interesting. While I was able to reproduce with a nightly, I can't reproduce with my local build...
For the record I can't reproduce it on OS X, either or Nightly or on my local build. This must be something Linux-specific.
(Reporter)

Comment 7

5 years ago
I can't reproduce with the latest nightly.
(Reporter)

Comment 8

5 years ago
So apparently, this has been fixed.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
\o/
You need to log in before you can comment on or make changes to this bug.