Frequent crashes in libgklayout.so

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: kmike, Assigned: karnaze (gone))

Tracking

({crash, dataloss})

Trunk
x86
Linux
crash, dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
i hate to file it in 'Browser-general', but i've no idea where it belongs to...
i'm experiencing a frequent crashes since i downloaded 2001051421 nightly.
no particular URL, just random crashes here and there.
here is a trace:

Program received signal SIGSEGV, Segmentation fault.
0x40dc7d15 in NSGetModule () from /home/mike/mozilla/components/libgklayout.so
(gdb) where
#0  0x40dc7d15 in NSGetModule ()
   from /home/mike/mozilla/components/libgklayout.so
#1  0x40dd5211 in NSGetModule ()
   from /home/mike/mozilla/components/libgklayout.so
#2  0x40dd7887 in NSGetModule ()
   from /home/mike/mozilla/components/libgklayout.so
#3  0x40cf83fe in NSGetModule ()
   from /home/mike/mozilla/components/libimglib2.so
#4  0x40cf6ee5 in NSGetModule ()
   from /home/mike/mozilla/components/libimglib2.so
#5  0x40cf4e4e in NSGetModule ()
   from /home/mike/mozilla/components/libimglib2.so
#6  0x408ff212 in NSGetModule ()
   from /home/mike/mozilla/components/libtimer_gtk.so
#7  0x408ff3dd in NSGetModule ()
   from /home/mike/mozilla/components/libtimer_gtk.so
#8  0x408ff463 in NSGetModule ()
   from /home/mike/mozilla/components/libtimer_gtk.so
#9  0x4063d864 in g_timeout_dispatch (source_data=0x82aebe0, 
    dispatch_time=0xbffff16c, user_data=0x0) at gmain.c:1302
#10 0x4063c9f6 in g_main_dispatch (dispatch_time=0xbffff16c) at gmain.c:656
#11 0x4063cfb1 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#12 0x4063d129 in g_main_run (loop=0x8150060) at gmain.c:935
#13 0x4055c48a in gtk_main () at gtkmain.c:524
#14 0x40494fdc in NSGetModule ()
   from /home/mike/mozilla/components/libwidget_gtk.so
#15 0x40475cea in NSGetModule ()
   from /home/mike/mozilla/components/libnsappshell.so
#16 0x804d1c4 in StringAllocator_char ()
#17 0x804da15 in StringAllocator_char ()
#18 0x401e39cb in __libc_start_main (
    main=0x804d8e8 <StringAllocator_char(void)+12888>, argc=1, 
    argv=0xbffff374, init=0x804a0e0 <_init>, fini=0x804f3d0 <_fini>, 
    rtld_fini=0x4000aea0 <_dl_fini>, stack_end=0xbffff36c)
    at ../sysdeps/generic/libc-start.c:92
should be layout...
Component: Browser-General → Layout

Comment 2

17 years ago
.
Assignee: asa → karnaze
QA Contact: doronr → petersen

Comment 3

17 years ago
Reporter, please pull the latest version. I tried to reproduce with the May 15th
build under Linux Redhat 6.2 but seems to work fine.

Comment 4

17 years ago
this bug bug nearly made me running mad with the 2001051421, but I can not
reproduce it on the 2001051508 build. seems to be magicly fixed...

Comment 5

17 years ago
I can't tell if this is the same bug, but I've been getting what seem to be
random crashes in GKLAYOUT.DLL the past few days.  I've finally sort of narrowed
it down to the following:
1) I start Mozilla, which defaults to a local HTML file for home page.
2) I go to Bookmarks and choose the one I have for News.com.
3) Crashes in GKLAYOUT.DLL.

However, if I move the mouse away quickly after choosing my News.com bookmark,
it doesn't crash.  Or if I keep the mouse away from that bookmark, and use the
cursor keys to select the bookmark, it doesn't crash.  This is about 90%
reproducible (infrequently, choosing the bookmark with the mouse doesn't crash)

I suspect it has to do with the contents of the page I'm using for a home page,
and the position of the mouse, but I don't know what other info to provide.

Comment 6

17 years ago
Doh!  Forgot to mention, this is build 2001051504, on Win98.

Comment 7

17 years ago
Oho!  I've found a way to reproduce this that doesn't depend on the position of
a bookmark.  Go to http://www.nnanime.com/staff.shtml.  Put the focus in the URL
bar, so you can type a new address.  Now move the mouse over the image map to
the 4th one (Megumi-Toons).  In the URL bar, type "www.news.com"  On my system,
this causes a crash in GKLAYOUT.  If I move the mouse over a text link, it
doesn't crash.

Comment 8

17 years ago
forgot what I said above.
reliable reproduced with 2001051508. -> confirm

I was using an internal page quite similar to
http://idealo.de/livesearch/livesearch/book_search.pl
i played abit on that page and get the crash after some tries.Sorry if this does
not help much, since I you can't reach the website I see the crashes on :-(

What is this GetModule after all? I see LOTS of crashes in this function. Can't
this function be made more robust?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

17 years ago
I dont know if it's the same bug, but I'm also getting seeming random crashes
under Linux in 2001051508.

Comment 10

17 years ago
this is a really annoying crasher, which happens several times a day. setting to
critical, since it is a crasher!
Severity: normal → critical

Comment 11

17 years ago
Jens-Uwe, can you see if the position of the cursor makes any difference for
whether you crash?  I'm almost sure that's what's causing the crashes that I
see.  If the cursor position makes a difference, you should be able to work
around the problem by making sure your cursor is not over an image map or a link.
(Reporter)

Comment 12

17 years ago
still crashing as of 2001051521 linux nightly build.
i noticed that crash occuring mostly when closing mozilla window.

Comment 13

17 years ago
I can reliable reproduce this crash:
go to www.dedecom.de and click on "Kontakt". Mozilla crashes with the same
stack.(2001051706 Linux)

QA: could you please put some weight behind this bug? it makes the linux builds
unusable. Its very likely a top crasher, but I don't have the statistics.

I cc pavlov, because the imagelib2 and the libtimer is mentioned in the stack
trace, so maybe it is connected? Feel free to remove yourself from the list if
it is not!
(Reporter)

Comment 14

17 years ago
confirming, i'm crashing at www.dedecom.de too. first time i got "Kontakt" page
displayed, but it crashed when i pressed "Back".


Comment 15

17 years ago
this is probably related to the crash when tables don't destroy their children
correctly..

Comment 16

17 years ago
I am using the Linux 2001052021 build for several hours now and did not
encounter this bug anymore. the reproducable crash at dedecom.de also disappeared. 
if it also works for some of you, this should be marked as works for me...

Comment 17

17 years ago
The problem I describe with www.nnanime.com still occurs on latest build.  It
was marked as 2001-05-21-10-STYLE on FTP, but the title bar says 2001052023.

Comment 18

17 years ago
warner: I can't reproduce the crashes at nnanime here, sorry :-(

Comment 19

17 years ago
I'm seeing what looks like a similar bug in the 2001052115 build on Linux.
To reproduce:

Go to http://www.guidescope.com.

Click on "Products" from the bar at the top. If the page loads, click the back
button and try again. I can get Mozilla to crash within 1-3 tries with the
following stack trace:

#0  0x40f5dd35 in NSGetModule ()
   from /usr/libexec/mozilla/components/libgklayout.so
#1  0x40f79919 in NSGetModule ()
   from /usr/libexec/mozilla/components/libgklayout.so
#2  0x40f79703 in NSGetModule ()
   from /usr/libexec/mozilla/components/libgklayout.so
#3  0x410b0806 in NSGetModule ()
   from /usr/libexec/mozilla/components/libgkview.so
#4  0x410b07ae in NSGetModule ()
   from /usr/libexec/mozilla/components/libgkview.so
#5  0x410b07ae in NSGetModule ()
   from /usr/libexec/mozilla/components/libgkview.so
#6  0x410b9ede in NSGetModule ()
   from /usr/libexec/mozilla/components/libgkview.so
#7  0x410b01ad in NSGetModule ()
   from /usr/libexec/mozilla/components/libgkview.so
#8  0x40731d6a in NSGetModule ()
   from /usr/libexec/mozilla/components/libwidget_gtk.so
#9  0x40731c95 in NSGetModule ()
   from /usr/libexec/mozilla/components/libwidget_gtk.so
#10 0x40731df0 in NSGetModule ()
   from /usr/libexec/mozilla/components/libwidget_gtk.so
#11 0x4073218d in NSGetModule ()
   from /usr/libexec/mozilla/components/libwidget_gtk.so
#12 0x40735e6f in NSGetModule ()
   from /usr/libexec/mozilla/components/libwidget_gtk.so
#13 0x4072ce07 in NSGetModule ()   from
/usr/libexec/mozilla/components/libwidget_gtk.so
#14 0x4072cb5c in NSGetModule ()
   from /usr/libexec/mozilla/components/libwidget_gtk.so
#15 0x4032b12b in gdk_event_dispatch (source_data=0x0, 
    current_time=0xbffff3dc, user_data=0x0) at gdkevents.c:2139
#16 0x4035b3d5 in g_main_dispatch (dispatch_time=0xbffff3dc) at gmain.c:656
#17 0x4035b9d0 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#18 0x4035bb68 in g_main_run (loop=0x8142ba8) at gmain.c:935
#19 0x40271213 in gtk_main () at gtkmain.c:524
#20 0x40724fdc in NSGetModule ()
   from /usr/libexec/mozilla/components/libwidget_gtk.so
#21 0x40705cea in NSGetModule ()
   from /usr/libexec/mozilla/components/libnsappshell.so
#22 0x804e6b4 in NS_CreateNativeAppSupport () at eval.c:41
#23 0x804ef05 in main () at eval.c:41
#24 0x40492e5e in __libc_start_main (main=0x804edd8 <main>, argc=1, 
    ubp_av=0xbffff61c, init=0x804b108 <_init>, fini=0x8050b90 <_fini>, 
    rtld_fini=0x4000d3c4 <_dl_fini>, stack_end=0xbffff614)
    at ../sysdeps/generic/libc-start.c:129

Comment 20

17 years ago
Chang Lin.  Yes, that looks like the same problem I have.  If I click on
Products and don't move my mouse, it crashes.  If I click on Products and
immediately move the mouse away, it doesn't crash.
(Reporter)

Comment 21

17 years ago
well, i was about to mark this one WORKSFORME, since 2001052121 nightly build
appears to be much stablier - no more crashing while closing mozilla windows.
but i just crashed trying Chang Lin's testcase..
alas.

Updated

17 years ago
Keywords: crash, dataloss

Comment 22

17 years ago
seem like the second stack looks a bit different then the 1st one. We don't go
through the timer and imglib2 anymore.

Comment 23

17 years ago
Using: Mozilla/5.0 (X11; U; Linux 2.2.18 i686; en-US; rv:0.9+) Gecko/20010523
BuildID: 2001052308

I took the www.guidescope.com page and made a simplified test case.
It's reachable at:
http://didntduck.org/~chiner/mozilla/80923.html
To cause the problem:
Click repeatedly on the image.  It always crashes for me, but sometimes it
takes 10-15 tries.  It seems to crash better if you're moving the mouse when you
click.
On crash, I get a stack like Chang Lin's.

The a href and the image map were both needed for me to be able to crash.

Hopefully this helps... This is an annoying bug.

Comment 24

17 years ago
Build 2001053009 doesn't seem to crash on either the guidescope.com link or the
didntduck.org link. <crosses fingers>

Comment 25

17 years ago
Works for me with linux 2001053008.  Neither my testcase, or the original
guidescope page makes it crash for me.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 26

17 years ago
I'm guessing this was fixed by bug 81728.  In any case, my test case no longer
crashes, either.
You need to log in before you can comment on or make changes to this bug.