If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[rule view] handling of ":" (colon) and ";" (semi-colon) key is inconsistent when double-clicking

RESOLVED INVALID

Status

()

Firefox
Developer Tools: Inspector
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: Florian Bender, Unassigned)

Tracking

17 Branch
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:17.0) Gecko/17.0 Firefox/17.0
Build ID: 20121031065642

Steps to reproduce:

Inspect the header in Bugzilla (right-click where it says "Bugzilla@Mozilla …", should be td#title > p). Add a new property to the inline style by **double**-clicking after `element {` and type `margin:`. 


Actual results:

The inspector jumps to a new line (new property) and the property added before gets a strike through. 


Expected results:

When typing the colon (:), the carret should jump to the next field, i. e. from property-descriptor to property-text instead. 


This bug may (or may not) be region-specific, can reproduce this on a German keyboard. May also be OS-specific (Mac OS X) or hardware-specific (MBA 2012). May also be an issue with the Macs touchpad: When I click, I actually **tap** (resp. double-tap).
(Reporter)

Updated

5 years ago
Component: Untriaged → Developer Tools: Inspector
Hardware: x86 → x86_64
(Reporter)

Updated

5 years ago
Duplicate of this bug: 809411

Updated

5 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: [style editing] handling of ":" (colon) and ";" (semi-colon) key is inconsistent when double-clicking → [rule view] handling of ":" (colon) and ";" (semi-colon) key is inconsistent when double-clicking
(Reporter)

Comment 2

4 years ago
Double-clicking now hides the input field, invalidating this bug.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.