[bedrock] /b/ redirect for legal/eula

VERIFIED FIXED

Status

Infrastructure & Operations
WebOps: Other
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: rik, Assigned: jakem)

Tracking

Details

(Whiteboard: [push interrupt])

(Reporter)

Description

6 years ago
Yup, another one!

RewriteRule ^/en-US/legal/eula(/?)$ /b/en-US/legal/eula$1 [PT]
RewriteRule ^/(\w{2,3}(?:-\w{2}(?:-mac)?)?/)?legal/eula(/?)$ /en-US/legal/eula$2 [L,R=302]
(Assignee)

Comment 1

6 years ago
Committed to puppet for dev and stage... will be live in 30min or less. After that, awaiting green-light for prod change.

Thanks!
Assignee: server-ops-webops → nmaul
Whiteboard: [push interrupt]

Updated

6 years ago
Duplicate of this bug: 809130

Comment 4

6 years ago
Thoughts on why dev might be borked? Could this have to do with the legacy PHP stuff?
(Reporter)

Comment 5

6 years ago
New code is not pushed to dev. Dev was used before we got the demo servers. So it is normal that this doesn't work because dev doesn't have the new eula page. I think this is good to go.
qa-verified-stage https://www.allizom.org/en-US/legal/eula/
(Assignee)

Comment 7

6 years ago
www-dev should be auto-deploying new code via cron... and it uses the same shared rewrites file... so it should be just as up-to-date as the demoX servers, assuming the code is in the branch that www-dev auto-updates (which appears to be "dev").

Of course if the code never gets to the "dev" branch, it won't appear on www-dev. I suspect that's what's happened here.

Comment 8

6 years ago
stage verified is good enough for me, push live when you can and Ill start the work on the legacy stuff.
(Assignee)

Comment 9

6 years ago
Rik, good to put this on prod?

Comment 10

6 years ago
Please push to production.
(Assignee)

Comment 11

6 years ago
This change is committed to prod. It will be visible within 30 minutes.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
verified fixed http://www.mozilla.org/en-US/legal/eula/
Status: RESOLVED → VERIFIED
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.