Port |Bug 792054 - Use the legacy User Agent string (containing Gecko/20100101) for some possibly-broken online banking sites|

RESOLVED FIXED in seamonkey2.16

Status

SeaMonkey
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: InvisibleSmiley, Assigned: InvisibleSmiley)

Tracking

Trunk
seamonkey2.16
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.14 fixed, seamonkey2.15 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
FF bug 792054 activated the legacy User Agent string (like previously done for Moodle) for some possibly-broken online banking sites. The change landed on Aurora and Beta, too. I think non-working banking sites are bad, so let's follow suit(e), shall we?

Original changesets:
http://hg.mozilla.org/mozilla-central/rev/fe3ddc3ce8e6
http://hg.mozilla.org/releases/mozilla-aurora/rev/33c470ea043e
http://hg.mozilla.org/releases/mozilla-beta/rev/cc85077c423b
(Assignee)

Comment 1

5 years ago
Created attachment 679237 [details] [diff] [review]
patch [Checkin: Comments 3 and 4]

Unfortunately I don't think I can test this since I'm not a customer of any of these banks. :-/
Assignee: nobody → jh
Status: NEW → ASSIGNED
Attachment #679237 - Flags: review?(iann_bugzilla)
Depends on: 792054

Updated

5 years ago
Attachment #679237 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Comment 2

5 years ago
Comment on attachment 679237 [details] [diff] [review]
patch [Checkin: Comments 3 and 4]

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 588909
User impact if declined: online banking may be broken on some banking sites until they fix their User Agent sniffing
Testing completed (on m-c, etc.): landed on m-c
Risk to taking this patch (and alternatives if risky): low risk
String or UUID changes made by this patch: none
Attachment #679237 - Flags: approval-comm-beta?
Attachment #679237 - Flags: approval-comm-aurora?
(Assignee)

Comment 3

5 years ago
Comment on attachment 679237 [details] [diff] [review]
patch [Checkin: Comments 3 and 4]

http://hg.mozilla.org/comm-central/rev/b835e68f8f8c
Attachment #679237 - Attachment description: patch → patch [Checkin: Comment 3]
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.16

Updated

5 years ago
Attachment #679237 - Flags: approval-comm-beta?
Attachment #679237 - Flags: approval-comm-beta+
Attachment #679237 - Flags: approval-comm-aurora?
Attachment #679237 - Flags: approval-comm-aurora+
(Assignee)

Comment 4

5 years ago
Comment on attachment 679237 [details] [diff] [review]
patch [Checkin: Comments 3 and 4]

http://hg.mozilla.org/releases/comm-aurora/rev/af40044655ae
http://hg.mozilla.org/releases/comm-beta/rev/de4387b45ac2

[If anyone wonders whether this will work on branches at all: Bug 786613 landed everywhere we want to land this. Unfortunately, 2.14b4 has already been tagged, so unless releng decides to respin, this will only be in 2.14b5.]
Attachment #679237 - Attachment description: patch [Checkin: Comment 3] → patch [Checkin: Comments 3 and 4]
(Assignee)

Updated

5 years ago
status-seamonkey2.14: --- → fixed
status-seamonkey2.15: --- → fixed
tracking-seamonkey2.14: ? → ---
(Assignee)

Updated

5 years ago
Blocks: 815801
You need to log in before you can comment on or make changes to this bug.