Generate a landing page template that will work for each Dev Hub section (Design, Build, Publish)

RESOLVED DUPLICATE of bug 832531

Status

Marketplace
Developer Pages
RESOLVED DUPLICATE of bug 832531
5 years ago
5 years ago

People

(Reporter: dbuc, Assigned: tsmuse)

Tracking

Points:
---
Dependency tree / graph

Details

(Whiteboard: u=dev c=design p=3 s=2013.2)

Attachments

(1 attachment, 1 obsolete attachment)

281.35 KB, application/pdf
Details
(Reporter)

Description

5 years ago
We need a landing page template that will work for each of the main sections of the Developer Hub - Design, Build, and Publish. The landing pages should provide for the following:

- Highlight the main activities for each section with visually pleasing, graphical UI (a slide, panel, or showcase element of some kind?).

- Provide call-to-action links to the primary interactive features contained within each section.

- In a secondary section, highlight other key elements of a given section, if applicable
(Reporter)

Updated

5 years ago
Assignee: nobody → bram

Updated

5 years ago
Whiteboard: u=dev c=design p=3

Comment 1

5 years ago
Created attachment 680951 [details]
Section landing pages

I haven’t finished the landing page for the “Publish” section yet, but the first two templates for “Design” and “Publish” should show you what I have in mind.

The basic idea is to summarize the content of each article inside that section in one sentence. Then, if relevant, display it sequentially.

Comment 2

5 years ago
Created attachment 681346 [details]
Section landing pages

The section landing page mockups have been updated with the addition of the “Publish” section.

Let me know what you guys think of it? When it’s all good, we can design a high-fidelity prototype before implementing it.
Attachment #680951 - Attachment is obsolete: true
(Reporter)

Comment 3

5 years ago
Tony, given you now have some insight into the most important content to developers in each of these sections, can you generate a landing page template (or series if they need to be very different from each other) that presents the most valuable content to the user?

I'd like to see the templates integrate some compelling visual features if possible (previous iterations were very text-heavy, which is a problem with many of the Dev Hub's current pages)
Assignee: bram → asantos
Depends on: 835566
Depends on: 835568
Depends on: 835571
Whiteboard: u=dev c=design p=3 → u=dev c=design p=3 s=2013.2
Blocks: 834582
(Reporter)

Comment 4

5 years ago
Hey Tony, do you have an ETA on this, it's blocking some of the MWC content implementations we have in-flight.
Forward-duping against bug 832531 for now; that's an IA iteration that'll encompass a number of landing pages.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 832531
You need to log in before you can comment on or make changes to this bug.