A stylesheet with an invalid regexp causes JS exceptions

RESOLVED DUPLICATE of bug 709954

Status

()

RESOLVED DUPLICATE of bug 709954
6 years ago
6 years ago

People

(Reporter: jason.barnabe, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
1. Install Stylish - https://addons.mozilla.org/en-US/firefox/addon/stylish/
2. Add a new style with this code: @-moz-document regexp("?") {}
3. Check the Error Console. You should see some errors saying "SyntaxError: invalid quantifier", some from specific lines in js files.
4. Use Orion by editing the style with Stylish or by activating Scratchpad. You'll find that you can't modify the text because of SyntaxError: invalid quantifier in chrome://browser/content/orion.js:5003.

I would not expect that a bad regexp in a stylesheet would cause JS exceptions.
This should have been fixed by bug 709954, as far as I can tell.  Do you see the problem in a nightly build?
(Reporter)

Comment 2

6 years ago
Yeah, fixed in 19.0a1.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 709954
You need to log in before you can comment on or make changes to this bug.