Closed Bug 809784 Opened 7 years ago Closed 7 years ago

java.lang.IllegalArgumentException: width and height must be > 0 at android.graphics.Bitmap.createBitmap(Bitmap.java)

Categories

(Firefox for Android :: General, defect, critical)

19 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox18 --- unaffected
firefox19 --- affected

People

(Reporter: scoobidiver, Unassigned)

References

Details

(Keywords: crash, regression, Whiteboard: [native-crash])

Crash Data

It first appeared in 19.0a1/20121018. The regression range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=dac5700acf8b&tochange=cb573b9307e5

Here is a crash report: bp-fdee5f70-c588-446e-a1a9-4fa312121108.

java.lang.IllegalArgumentException: width and height must be > 0
	at android.graphics.Bitmap.createBitmap(Bitmap.java:603)
	at android.graphics.Bitmap.createBitmap(Bitmap.java:585)
	at org.mozilla.gecko.Tab.getThumbnailBitmap(Tab.java:179)
	at org.mozilla.gecko.GeckoApp.handleThumbnailData(GeckoApp.java:732)
	at org.mozilla.gecko.ScreenshotHandler$2.run(ScreenshotHandler.java:370)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at org.mozilla.gecko.util.GeckoBackgroundThread.run(GeckoBackgroundThread.java:31)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.IllegalArgumentException%3A+width+and+height+must+be+%3E+0+at+android.graphics.Bitmap.createBitmap%28Bitmap.java%29
Although it's before the range, I think this is a regression from bug 787765. We've had a few other related regressions because of the thumbnail size changes.
Blocks: 787765
Crashes have stopped since 19.0a1/20121109.
There's only one crash in 19.0.2 so let's close it.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.