Click to play overlay not appearing on wikipedia.org

RESOLVED INVALID

Status

()

Core
Plug-ins
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Manuela Muntean [Away], Unassigned)

Tracking

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [testday-20121108])

(Reporter)

Description

5 years ago
Firefox 17 beta 5 (20121106195758) Flash 11.5

STR:
1. Activate click to play and restart Firefox.
2. Load http://en.wikipedia.org/wiki/Screencast in the browser.

Actual Results:
The overlay for enabling the video is not visible. 

Expected:
The overlay for enabling the video should appear.
(Reporter)

Updated

5 years ago
Blocks: 738698

Comment 1

5 years ago
It seems to work with FF19.
The default player is HTML5 Ogg Player so CTP doesn't apply in such a case because it doesn't require a 3rd-party plugin to stream, but the user is able to switch to the Cortado Java applet to stream (http://www.flumotion.net/cortado/).
When the Java Cortado is selected in the player options, I'm able to see the CTP overlay (see http://i.imgur.com/RkYwR.jpg) and enabling Java plugin works when I click.

The CTP overlay is not immediately visible because the player is embedding an initial splash image (ex: http://flash.flowplayer.org/demos/standalone/installation/splash-image.html).
(Reporter)

Updated

5 years ago
OS: Windows 7 → All

Comment 2

5 years ago
I cannot reproduce this on nightly either. If this is a regression that was fixed between FF17 and current nightly, Manuela can you perhaps look for a "fix range" to see what we landed that fixed this?
The video is not plug-in content, it is HTML5 video. I don't think CTP applies to HTML5 video.

<video tabindex="0" style="width: 100%; height: 100%; z-index: 1;" src="//upload.wikimedia.org/wikipedia/commons/d/da/Adjusting_photo_with_levels.ogg" id="pid_mwe_player_0" class="nativeEmbedPlayerPid"></video>

Please reopen if this is an incorrect assumption.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Whiteboard: [testday-20121108]

Comment 4

5 years ago
Anthony, check the player options, it provides Java streaming too. ;)
But even with the Java player selected, the CTP overlay is visible and works after the user clicked on the splash image.
I only see an option for "HTML5 Ogg Player", I see no Java player option. But that's besides the point if you confirm the Java player is working for you. That does not have any bearing on the INVALID status of this bug.
You need to log in before you can comment on or make changes to this bug.