If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

NTLM Authentication does not work on Windows 8

RESOLVED INVALID

Status

()

Core
Networking: HTTP
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: St Heine, Unassigned)

Tracking

16 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0
Build ID: 20121024073032

Steps to reproduce:

I'm new to Windows 8, and installed Firefox 16.0.2.
I'm trying to access a number of company internal websites protected by NTLM Authentication.

I also added the domain into network.automatic-ntlm-auth.trusted-uris (.company.com) to enable this, and also switched network.automatic-ntlm-auth.allow-proxies to false.

the same Firefox configuration works fine on a Windows 7 system, and Internet Explorer on the same Windows 8 system correctly accesses the NTLM Authenticated sites.


Actual results:

The Firefox on Windows 8 comes up with a 'Authentication Required: Enter username and password for ...' box.
Even entering the correct credentials does not allow accessing these sites.


Expected results:

Firefox should simply use the logged on users' authentication for the NTLM Authentication request.
Component: Untriaged → Networking: HTTP
Product: Firefox → Core
Stefan: Do you get the NTLM dialog box over and over again when entering the correct credentials? Then this bug might be a dupe of Bug 779467. The bug fix should be included in Firefox 19 and possibly also in the Firefox 17 extended service release version.
(Reporter)

Comment 2

5 years ago
Frank, yes it does. and even though about that other bug you referenced, it pointed me to a solution: my issue was related to the proxy connection to the NTLM-authenticating server. After setting that system name into 'No proxy for', I succeeded, using NTLM authentication.
and that's the same behavior as in Windows 7, so there's no regression in Firefox.

you can close this bug as user-error.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.