MXR isn't indexing the elm branch

RESOLVED WORKSFORME

Status

Developer Services
General
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: jimm, Assigned: fubar)

Tracking

Details

(URL)

(Reporter)

Description

6 years ago
For some reason it look like we lost MXR updates about a month ago for the elm project repo. Looks like it may have started back when we had all those networking problems on Oct 12th.
(Reporter)

Updated

6 years ago
Assignee: nobody → server-ops-releng
Component: General → Server Operations: RelEng
Product: Webtools → mozilla.org
QA Contact: arich
Version: Trunk → other
Not sure which component this goes in, but I'll start with general releng as the most likely.
Assignee: server-ops-releng → nobody
Component: Server Operations: RelEng → Release Engineering
QA Contact: arich
mxr is fox2mike's team. FWIW, I don't see an Elm on http://mxr.mozilla.org/ at all.
Component: Release Engineering → Release Engineering: Developer Tools
QA Contact: hwine
Assignee: nobody → server-ops-devservices
Component: Release Engineering: Developer Tools → Server Operations: Developer Services
QA Contact: hwine → shyam

Comment 3

6 years ago
The root doesn't necessarily advertise all roots,

http://mxr.mozilla.org/mozilla-central/search has a drop down which will show all roots ("using tree:"), I don't see anything particularly "elm-ISH" there.

I think Jimm got to Elm from:
http://mxr.mozilla.org/projects-central/source/elm/

Which is various magical bits to try to retrieve all projects things. 

Jimm, please correct me (and the URL) if I'm wrong.
(In reply to Nick Thomas [:nthomas] from comment #2)
> mxr is fox2mike's team. FWIW, I don't see an Elm on http://mxr.mozilla.org/
> at all.

Are there any other disposable project branches on mxr? I'm sure they're called "Disposable" for a reason?
(Reporter)

Comment 5

6 years ago
(In reply to timeless from comment #3)
> I think Jimm got to Elm from:
> http://mxr.mozilla.org/projects-central/source/elm/
> 
> Which is various magical bits to try to retrieve all projects things. 
> 
> Jimm, please correct me (and the URL) if I'm wrong.

Yep, that's what we use. We don't do a lot searching due to latency, but we do reference links into annotated code in bugs and such, which seems to be way out of date. For example - 

http://mxr.mozilla.org/projects-central/source/elm/widget/windows/winrt/

still shows src prior to a checkin on elm  on Wed Oct 31 07:06:14 2012 PST. Normally we would see updates within 24 hours or so.
I'll repeat my comment #4 here again, I'm not sure we index disposable project branches at all?
Assignee: server-ops-devservices → klibby
We do, and we have it -- it is entirely possible it is out of date though and needs hands on to reset it in mxr though:

http://mxr.mozilla.org/projects-central/source/elm/

(the mxr tree is "projects-central" but it contains multiple project branches in it)
(Reporter)

Comment 8

5 years ago
I think the problem is that updating the index is taking a really long time. Looking at the current index I can't really tell how stale it is, I do see that some checkins from last week are not reflected. FWIW, we aren't using elm anymore so this is not critical for our project.
(Reporter)

Comment 9

5 years ago
(In reply to Jim Mathies [:jimm] from comment #8)
> I think the problem is that updating the index is taking a really long time.
> Looking at the current index I can't really tell how stale it is, I do see
> that some checkins from last week are not reflected. FWIW, we aren't using
> elm anymore so this is not critical for our project.

oh, pfft - it hasn't been merged with mc, so I really don't know how fast it's indexing currently.
(Assignee)

Comment 10

5 years ago
It's entirely possible that I'm missing something as I'm still learning the vagaries of MXR, but it looks like elm's currently up to date.

http://hg.mozilla.org/projects/elm/pushloghtml?&enddate=now&path=&startdate=1+month+ago

User
Push date [To Local]	Changeset	Patch author — Commit message
nthomas@mozilla.com
Mon Mar 18 20:32:42 2013 -0700	da31724af637

which matches a new clone:
$hg tip
changeset:   124578:da31724af637
tag:         tip
user:        Nick Thomas <nthomas@mozilla.com>
date:        Tue Mar 19 16:31:42 2013 +1300
summary:     Bug 840541, repatriate nightly-elm users to nightly (mozilla-central)

Indexing the projects-central section certainly does take a while (12-14hrs), but appears to be running on a regular basis without errors. 

If you can point me to something specific that's out of whack I can dig further; alternatively, if the above is sufficient and it's not critical, feel free to resolve/wfm?
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Component: Server Operations: Developer Services → General
Product: mozilla.org → Developer Services
You need to log in before you can comment on or make changes to this bug.