Last Comment Bug 809853 - Thunderbird Nightly on Mac and Linux is broken (doesn't start - Couldn't load XPCOM)
: Thunderbird Nightly on Mac and Linux is broken (doesn't start - Couldn't load...
Status: RESOLVED FIXED
: dogfood, regression
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: 19 Branch
: x86 All
: -- blocker (vote)
: Thunderbird 19.0
Assigned To: Mike Conley (:mconley) - (needinfo me!)
:
:
Mentors:
Depends on:
Blocks: 779997
  Show dependency treegraph
 
Reported: 2012-11-08 06:37 PST by Ludovic Hirlimann [:Usul]
Modified: 2012-11-29 02:19 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Packaging fix (602 bytes, patch)
2012-11-08 07:55 PST, Mike Conley (:mconley) - (needinfo me!)
irving: review+
Details | Diff | Splinter Review

Description Ludovic Hirlimann [:Usul] 2012-11-08 06:37:38 PST
This is what I get When I start it from the Terminal :

Oulan:~ ludo$ /Applications/Daily.app/Contents/MacOS/thunderbird
XPCOMGlueLoad error 4:0 for file /Applications/Daily.app/Contents/MacOS/libxpcom.dylib:
Library not loaded: @executable_path/libsoundtouch.dylib
  Referenced from: /Applications/Daily.app/Contents/MacOS/XUL
  Reason: image not found
Couldn't load XPCOM.
Comment 1 Mike Conley (:mconley) - (needinfo me!) 2012-11-08 06:45:20 PST
Sounds like a building foul-up...
Comment 2 Robert Kaiser 2012-11-08 06:53:00 PST
I've seen the same for SeaMonkey on Linux, and yesterday's build worked.
From looking at SeaMonkey tinderbox, I expect that the failure happened in this range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=bb4d68b03164&tochange=c652c39732f8
Comment 3 Robert Kaiser 2012-11-08 06:56:41 PST
Adding Callek after seeing that mconley seems to have nailed it to packaging miss of bug 779997 on IRC - SeaMonkey will need the packaging fix as well, I guess.
Comment 4 Jonathan Protzenko [:protz] 2012-11-08 07:01:24 PST
Seeing this on Linux as well.
Comment 5 Mike Conley (:mconley) - (needinfo me!) 2012-11-08 07:04:01 PST
I'll see what I can do. Building...
Comment 6 Mike Conley (:mconley) - (needinfo me!) 2012-11-08 07:55:37 PST
Created attachment 679688 [details] [diff] [review]
Packaging fix

Ok, so I'm pretty sure this is all we need.

Unfortunately, I couldn't seem to reproduce the start-up failure on my local build, so I couldn't see if this actually fixed the problem. Weird, I know.

Anyhow, I'm pretty sure this is the fix we need.
Comment 7 :Irving Reid (No longer working on Firefox) 2012-11-08 09:12:44 PST
Comment on attachment 679688 [details] [diff] [review]
Packaging fix

Review of attachment 679688 [details] [diff] [review]:
-----------------------------------------------------------------

I can't see anything else we should need; r+ as long as the try build works.
Comment 8 Ludovic Hirlimann [:Usul] 2012-11-09 00:53:03 PST
This seems to have been pushed, mike any reasons you had *not* to close the bug ?
Comment 9 Jonathan Protzenko [:protz] 2012-11-09 04:40:16 PST
I ran the latest tinderbox build after you pushed and everything is fine now for me! Thanks Mike!
Comment 10 Mike Conley (:mconley) - (needinfo me!) 2012-11-09 06:30:43 PST
(In reply to Ludovic Hirlimann [:Usul] from comment #8)
> This seems to have been pushed, mike any reasons you had *not* to close the
> bug ?

Was just waiting for confirmation that we were back in business. Woo!

Note You need to log in before you can comment on or make changes to this bug.