Closed Bug 809867 Opened 9 years ago Closed 9 years ago

http://www.jukeboxalive.com/ doesn't work with CTP enabled

Categories

(Core :: Plug-ins, defect)

17 Branch
x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: pauly, Unassigned)

References

Details

Attachments

(1 file)

STR:
1. Set plugins.click_to_play=TRUE in about:config
2. Go to http://www.jukeboxalive.com/
3. Click on the play button next to a music category

Actual results:
Blank popup opens

Expected results:
A popup playing music should open
It works only if the user enables the Flash plugin through the CTP placeholder in the location bar of the tab (not in the popup window).

In addition, this page requests 2 plugins (Flash and unknown). Enabling Flash plugin is enough to stream the audio.
It seems that this is working as intended?
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
Negative. A notification should show up according to bug 819992, but it doesn't.
Why would we show a notification? The Flash plugin is fully visible, so there is no need for any notification popups.
The behavior is special:

1) When the user is on the website, the CTP doorhanger is present in the location bar.
2) When the user clicks on a link to play the music, a pop-up appears (the player) but stays blank and there is no CTP doorhanger in the pop-up location bar.
3) Then, if the user activates Flash via the doorhanger on the main tab, the pop-up displays the CTP layout (white brick) and the user is able to activate Flash in the pop-up.
Reopening based on comment 3 and 5.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Blocks: 810082, 819992
There is no bug here. There is no Flash player in the popup window, and the Flash player in the main window works fine when you click on it.
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → INVALID
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #7)
There is no Flash player in the popup window
http://img201.imageshack.us/img201/1215/flashx.png
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #7)
> There is no bug here. There is no Flash player in the popup window, and the
> Flash player in the main window works fine when you click on it.

Did you test the website before claiming that? Because the pop-up opens a Flash player to read the audio. 

Check my screenshot, I detailed the steps.

I think there are 2 bugs here:

1) The pop-up is open with blank content without CTP notifications (doorhanger or white brick) for the user.

2) Opening a pop-up makes the CTP doorhanger disappear on the main tab.
#1 is a website issue. They don't use Flash in the popup window until the user chooses to play the Flash in the main window. We're not going to fix or track that.

#2 Doesn't sound like a bug to me. The doorhanger is a temporary notification on purpose and should dismiss itself when some other navigation/window event happens.
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #10)
> They don't use Flash in the popup window until the
> user chooses to play the Flash in the main window
I'm still not understanding this. You have to click play first in the main window to be able to see the popup. I click play in the main window so the popup should play. See the behavior with CTP off.

And besides that, if using an old Flash, a red icon + a notification should be displayed for the CTP blocklist according to bug 819992. Now the notification won't appear.
I agree with bsmedberg - this sounds like a combination of a couple of CTP edge cases that can be worked around by the impacted website or resolved when the user updates to the latest version of Flash.
You need to log in before you can comment on or make changes to this bug.