Parsing error prevents work submission

RESOLVED FIXED

Status

Mozilla Developer Network
Editing
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: mgalli, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 679721 [details]
Screen Shot 2012-11-08 at 3.18.58 PM.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:19.0) Gecko/19.0 Firefox/19.0
Build ID: 20121106030712

Steps to reproduce:

I tried to translate my old article back from the Mozilla year 2000 days. 


Actual results:

When clicked save a parsing error was shown


Expected results:

to work
I think we just need to remove the {{ languages }} call. Sheppy: Can you say more about this?
This was fixed by removing the {{ languages }} template. Obrigado, mgalli!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

5 years ago
Hi John, 

What is the reasoning here to fix? I mean, is this something you fixed in the actual document? I just saw this note in the ENglish version too — can i do it myself when I see this or should I reopen this bug for the en version of the article?
Good question.

You can fix it yourself any time by removing the "languages" template from the document. For example, the page you mentioned had the following at the very end of the document.

<p>{{ languages( { "fr": "fr/Explorer_un_tableau_HTML_avec_des_interfaces_DOM_et_JavaScript", "ja": "ja/Traversing_an_HTML_table_with_JavaScript_and_DOM_Interfaces", "zh-cn": "cn/\u4f7f\u7528Javascript\u548cDOM_Interfaces\u6765\u5904\u7406HTML" } ) }}</p>

To fix the problem, I just removed that whole section.

Very sorry about this problem, by the way. We are looking into a more permanent fix with bug 811797.

Comment 5

5 years ago
Hi there! If you make new translation page, please try pressing CTRL + F5 on English page. If the problem had occurred, please try use this tool. 

http://jsfiddle.net/ethertank/Nftet/embedded/result/

This is still under construction.
But, some English page's problem will fix.
Maybe !  :-)
You need to log in before you can comment on or make changes to this bug.