Closed Bug 809972 Opened 9 years ago Closed 9 years ago

settings.js: gracefully handle missing nsIAudioManager on desktop builds

Categories

(Firefox OS Graveyard :: General, defect, P1)

defect

Tracking

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed)

RESOLVED FIXED
B2G C1 (to 19nov)
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed

People

(Reporter: philikon, Assigned: philikon)

References

Details

Attachments

(1 file, 1 obsolete file)

Bug 791642 broke the desktop builds. settings.js now tries to access Ci.nsIAudioManager no matter what. We should handle this gracefully to not break desktop builds.
Nom'ing for basecamp blocking because desktop build breakage = sad panda.
blocking-basecamp: --- → ?
Attached patch v1 (obsolete) — Splinter Review
Assignee: nobody → philipp
Attachment #679765 - Flags: review?(fabrice)
Dupe of bug 809577, slightly different fix. I tend to prefer this one though.
Attachment #679765 - Flags: review?(fabrice) → review+
Duplicate of this bug: 809577
Note that I had already landed bug 809577 on inbound when it was duped to this one, so the patch here will need to be rebased.
https://hg.mozilla.org/integration/mozilla-inbound/rev/6f9dd07d9d64
Depends on: 809577
Attached patch v2 r=fabriceSplinter Review
Attachment #679765 - Attachment is obsolete: true
Duplicate of this bug: 810043
https://hg.mozilla.org/mozilla-central/rev/61936d1ce9db
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
I'd like to ask for approval to land this on aurora as well.  This fix makes it possible to change the locale (among other settings) in the desktop build.  It's important to our localization effort and testing.
No longer depends on: 809577
Comment on attachment 679777 [details] [diff] [review]
v2 r=fabrice

Requesting approval-mozilla-aurora in case blocking-basecamp is denied.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 791642 
User impact if declined: see comment 10
Testing completed (on m-c, etc.): Already tested on m-c / b2g nightlies.
Risk to taking this patch (and alternatives if risky): virtually none
String or UUID changes made by this patch: none
Attachment #679777 - Flags: approval-mozilla-aurora?
l10n blocker, approving for Aurora 18.
blocking-basecamp: ? → +
Priority: -- → P1
Target Milestone: --- → B2G C1 (to 19nov)
Attachment #679777 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.