GPS status icon does not appear when enabled

RESOLVED INVALID

Status

Firefox OS
Gaia::System
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 679902 [details]
screenshot

The GPS icon does not appear when enabling GPS.   

See screenshot.

Repro:
1) install daily unagi build 11-8-2012
* BuildID=20121108071547
2) settings > enable GPS
3) Verify the GPS icon no longer shows up at the top

Expected:
- GPS icon appears everytime you toggle it on

ActuaL:
- GPS icon not shown.
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → ?

Updated

6 years ago
Component: Gaia → Gaia::System
Does the icon must be shown when gps is not in use ?
Flags: needinfo?(jcarpenter)
> Does the icon must be shown when gps is not in use ?

No. The geolocation indicator in the status bar only appears when an app is using (or has recently used) the geolocation permission.
Flags: needinfo?(jcarpenter)
(In reply to Josh Carpenter [:jcarpenter] from comment #2)
> > Does the icon must be shown when gps is not in use ?
> 
> No. The geolocation indicator in the status bar only appears when an app is
> using (or has recently used) the geolocation permission.

Sounds like this bug is INVALID then. I tend to agree that's the right behavior you've described too.
Status: NEW → RESOLVED
blocking-basecamp: ? → ---
Last Resolved: 6 years ago
Resolution: --- → INVALID
Duplicate of this bug: 806637
You need to log in before you can comment on or make changes to this bug.