MMI Codes do not work when no SIM Card is inserted

RESOLVED FIXED in B2G C2 (20nov-10dec)

Status

P1
major
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: dcoloma, Assigned: gtorodelvalle)

Tracking

unspecified
B2G C2 (20nov-10dec)
x86
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
The MMI codes such as *#06# should work even without a SIM inserted, as they do not require cellular connectivity.

STR:

 - Open the dialer in a device without a SIM Card
 - Dial *#06#

RESULT: Nothing happens

EXPECTED RESULT: The device IMEI is returned.
(Reporter)

Updated

6 years ago
blocking-basecamp: --- → ?
Blocks: 796657
No longer blocks: 793178
Germán, can you take a look at this issue, please?
Assignee: nobody → gtorodelvalle
Is it mandatory for certification ?
Flags: needinfo?(dcoloma)
This is Mandatory for certification. 
The reason of the high importance level is that devices are registered by operator when they are sold. In some countries, Operator subsidise the devices sold. 
When a shop assintant sell the product under the subsidise of an operator, then the shop assistant should ask for the money back to the operator. The only way they use to track the devices sold and avoid any issue is the IMEI.
Pleas keep in mind this key is very important.

Then in the shop, the shop assistant will turn the device on to trackle the IMEI. He will not include any SIM card, because the device is already sold and he cannot waste time :-( and will use MMI code to read the IMEI.

Sorry for this long speech, but I want to emphasize that there is a good reason behind this request.

Comment 4

6 years ago
certification required, blocking, p1
Severity: normal → major
blocking-basecamp: ? → +
Flags: needinfo?(dcoloma) → needinfo+
Flags: needinfo?(dcoloma)
Priority: -- → P1
I have it solved :-) Just waiting for https://github.com/mozilla-b2g/gaia/pull/6404 to land. ASA it does, I will prepare a new PR for this bug ;-)

Updated

6 years ago
Component: Gaia → Gaia::Dialer

Comment 6

6 years ago
Marking for C2, given this meets the criteria of known P1/P2 blocking-basecamp+ bugs at the end of C1.
Target Milestone: --- → B2G C2 (20nov-10dec)
Created attachment 684000 [details] [diff] [review]
Associated PR diff file.

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #684000 - Flags: review?(jmcf)
Attachment #684000 - Flags: approval-gaia-master?(francisco.jordano)
Comment on attachment 684000 [details] [diff] [review]
Associated PR diff file.

You don't need to ask for approval-gaia-master if the bug is set as blocking-basecamp+
Attachment #684000 - Flags: approval-gaia-master?(francisco.jordano)
Comment on attachment 684000 [details] [diff] [review]
Associated PR diff file.

Review of attachment 684000 [details] [diff] [review]:
-----------------------------------------------------------------

Drive-by review...

::: apps/communications/dialer/js/dialer.js
@@ +155,4 @@
>      });
>    }
>  
> +  function isMMI(number) {

This code is a dup of the one at [1]. I would prefer not to duplicate all this expensive parsing process and just look for '*' and/or '#' characters, as we've been doing so far.

[1]http://mxr.mozilla.org/mozilla-central/source/dom/system/gonk/ril_worker.js#2266
Attachment #684000 - Flags: review-
Hi :ferjm :) Please, contact me via Skype to discuss about this ;-) Thanks!
See Also: → bug 813679
After commenting it with :ferjm as well as with Beatriz (due to https://bugzilla.mozilla.org/show_bug.cgi?id=813679), we decided the following: A valid USSD/MMI code is any 'number' starting with #, or starting with * and with no * or # at the end. The USSD/MMI codes will be sent even if there is no SIM card available. In case of airplane mode, the USSD/MMI codes won't be sent either the phone number dialed.
Created attachment 684380 [details] [diff] [review]
Associated new PR diff file.

NOTE: If blocking-basecamp+ is set, just land it for now.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
Attachment #684380 - Flags: review?(jmcf)
Attachment #684380 - Flags: approval-gaia-master?(francisco.jordano)
Updated PR link (the same as before): https://github.com/mozilla-b2g/gaia/pull/6556
(In reply to gtorodelvalle from comment #12)
> After commenting it with :ferjm as well as with Beatriz (due to
> https://bugzilla.mozilla.org/show_bug.cgi?id=813679), we decided the
> following:

Thanks Germán. I am afraid that I might not explained myself properly.

> A valid USSD/MMI code is any 'number' starting with #, or
> starting with * and with no * or # at the end. 

This is not correct. Just look for * and/or # in the dial number. Nothing else. If the dial number contains * and/or #, you have to call |sendMMI(dialNumber)|.

>The USSD/MMI codes will be
> sent even if there is no SIM card available.

Exactly! This is the purpose of this bug :)

>In case of airplane mode, the
> USSD/MMI codes won't be sent either the phone number dialed.

I am afraid that you would need to send the MMI even if the phone is in airplane mode. Note that there are MMI codes associated to functionality that does not require any kind of radio activity (get the IMEI, for example). MMI codes that triggers radio services would fail in this case, but that is totally expected.

Thanks for all the work Germán and sorry for the misunderstanding!
No, no, sorry from my side! Definitely we understand much better each other in English than in Spanish or Andalusian :-p Implementing it right now!
Comment on attachment 684380 [details] [diff] [review]
Associated new PR diff file.

German you don't need the approval gaia master when the bug is bb+

Thanks.
Attachment #684380 - Flags: approval-gaia-master?(francisco.jordano)

Comment 18

6 years ago
German, is better to put a link to the PR in GH as attachment. See for example bug 813490

Updated

6 years ago
Attachment #684380 - Flags: review?(jmcf) → review+
PR landed in Gaia ;-)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Blocks: 819528

Updated

6 years ago
Attachment #684000 - Flags: review?(jmcf)
You need to log in before you can comment on or make changes to this bug.