Last Comment Bug 810215 - "explicit/atoms-table" reporter always returns 0
: "explicit/atoms-table" reporter always returns 0
Status: RESOLVED FIXED
[MemShrink]
:
Product: Core
Classification: Components
Component: XPCOM (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla19
Assigned To: Nicholas Nethercote [:njn]
:
Mentors:
Depends on:
Blocks: DarkMatter
  Show dependency treegraph
 
Reported: 2012-11-09 00:34 PST by Nicholas Nethercote [:njn]
Modified: 2012-11-13 17:06 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Fix stupid defect causing the "explicit/atoms-table" reporter to always return 0. (1020 bytes, patch)
2012-11-09 00:46 PST, Nicholas Nethercote [:njn]
khuey: review+
justin.lebar+bug: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Nicholas Nethercote [:njn] 2012-11-09 00:34:11 PST
"explicit/atoms-table" reporter always returns 0, due to a stupid and trivial defect.
Comment 1 Nicholas Nethercote [:njn] 2012-11-09 00:46:55 PST
Created attachment 680010 [details] [diff] [review]
Fix stupid defect causing the "explicit/atoms-table" reporter to always return 0.

Trivial fix.
Comment 2 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-11-09 11:17:23 PST
Comment on attachment 680010 [details] [diff] [review]
Fix stupid defect causing the "explicit/atoms-table" reporter to always return 0.

Review of attachment 680010 [details] [diff] [review]:
-----------------------------------------------------------------

ha
Comment 3 Justin Lebar (not reading bugmail) 2012-11-09 13:44:58 PST
Comment on attachment 680010 [details] [diff] [review]
Fix stupid defect causing the "explicit/atoms-table" reporter to always return 0.

Simple memory reporter fix; a-a+ if you want it.
Comment 4 Nicholas Nethercote [:njn] 2012-11-11 14:58:23 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/1ac4c8b22172

> Simple memory reporter fix; a-a+ if you want it.

Yes please.  On b2g-desktop64 I'm seeing sizes of 300--500 KiB per-process on startup, which is up to 2.5% of "explicit".  So this is a big missing chunk.
Comment 5 Phil Ringnalda (:philor, back in August) 2012-11-12 21:23:12 PST
https://hg.mozilla.org/mozilla-central/rev/1ac4c8b22172
Comment 6 Ryan VanderMeulen [:RyanVM] 2012-11-13 17:06:17 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/eff0efa2ae52

Note You need to log in before you can comment on or make changes to this bug.