After setup "SOCKS v5 Host" proxy configuration in preference unable to go back into preference also unable to restart mozilla

RESOLVED WORKSFORME

Status

--
blocker
RESOLVED WORKSFORME
18 years ago
14 years ago

People

(Reporter: jimmyu, Assigned: mcafee)

Tracking

({qawanted})

Trunk
x86
Linux
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Linux build ID 2001051508

Reproducible: always
Steps to reproduce:
1) start mozilla
2) Edit|Preferences|Advanced|Proxies|Manual proxy configuration
3) set "Manual proxy configuration" at york:3128
4) click "Ok"
5) now go back to Edit|Preferences

Results: nothing
Expected result : open Preferences window

6) exit mozilla
7) restart mozilla

Results: nothing, back to command prompt
Expect result : mozilla browser comes up
(Reporter)

Updated

18 years ago
Summary: After proxy configuration in preference unable to go back into preference also unable to restart mozilla → After setup proxy configuration in preference unable to go back into preference also unable to restart mozilla

Comment 1

18 years ago
qa to me.

What happens if you use console?

Also, if you remove all the proxy related entries in prefs.js
(network.proxy.*), does the problem go away?
QA Contact: tever → benc
(Reporter)

Comment 2

18 years ago
yes, problem goes away if prefs.js proxy related entries are removed.

what do you mean by using console?

Updated

18 years ago
Keywords: qawanted

Comment 3

18 years ago
Ben: could you test this out? 

Thanks,
Neeti
(Reporter)

Comment 4

18 years ago
Ok, looks like this problem only happens for "SOCKS v5 Host" configuration
setup. If manual proxy configuration have been enter for this entry then this
problem will happen.

The others configuration setup for FTP, Gopher, HTTP and SSL are fine.
Summary: After setup proxy configuration in preference unable to go back into preference also unable to restart mozilla → After setup "SOCKS v5 Host" proxy configuration in preference unable to go back into preference also unable to restart mozilla

Comment 5

18 years ago
I get the following asserions

###!!! ASSERTION: NS_ENSURE_TRUE(NS_SUCCEEDED(stringBundleService-> CreateBundle
("chrome://global/locale/appstrings.properties", aStringBundle))) failed: '(!((s
tringBundleService-> CreateBundle("chrome://global/locale/appstrings.properties"
, aStringBundle)) & 0x80000000))', file l:\build\mozilla\docshell\base\nsDocShel
l.cpp, line 5115
###!!! ASSERTION: NS_ENSURE_TRUE(window) failed: 'window', file l:\build\mozilla
\xpfe\appshell\src\nsContentTreeOwner.cpp, line 576
###!!! ASSERTION: NS_ENSURE_TRUE(docShellElement) failed: 'docShellElement', fil
e l:\build\mozilla\xpfe\appshell\src\nsXULWindow.cpp, line 938
###!!! ASSERTION: NS_ENSURE_TRUE(windowElement) failed: 'windowElement', file l:
\build\mozilla\xpfe\appshell\src\nsXULWindow.cpp, line 958
###!!! ASSERTION: no xul:window: 'windowElement', file l:\build\mozilla\xpfe\app
shell\src\nsXULWindow.cpp, line 751
Assignee: neeti → mcafee
Component: Networking → Preferences
QA Contact: benc → sairuh

Comment 6

18 years ago
re: console... do step 7 w/ -console flag, what do you see in the conosle window?

If this bug is the prefs problem, then the startup problem should be made a new
bug (unless you see a PAC loading comment in console, then it might be a dupe).
QA Contact: sairuh → benc
(Assignee)

Comment 7

18 years ago
pref window has been flakey, tried this on w2k & linux, seems
to work for me now.  Marking WFM, please reopen if you still see this.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.