Closed Bug 810275 Opened 9 years ago Closed 7 years ago

Scrolling on some sites isn't smooth

Categories

(Core :: Layout, defect)

18 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla20

People

(Reporter: Virtual, Assigned: mattwoodrow)

References

Details

(Keywords: nightly-community, regression, Whiteboard: [Snappy])

Attachments

(1 file)

Go to http://myanimelist.net/animelist/Oosran&status=7&order=0 and start scrolling. Scrolling with mouse isn't smooth and feels very heavy. Scrolling with scrollbar use 100% CPU core power.
Blocks: dlbi
Component: Untriaged → Layout
Product: Firefox → Core
Additional info:
It not happens with HW Acc disabled
The primary problem here is that the page has a fixed background image, but it isn't on the canvas frame. We don't layerize that, so we have to repaint everything when we scroll.

The patch fixes a smaller bug, but doesn't help on this example since we the image invalidates the same pixels.
Attachment #683396 - Flags: review?(roc)
I'm confused about why this is a regression, then. We've always repainted the world for such pages.
We should profile painting performance here. The page isn't complicated, we should be able to paint it pretty fast with D2D, and that's probably the right way to fix this bug.
https://hg.mozilla.org/integration/mozilla-inbound/rev/58ce0ddf7611

I suspect that the large amount of nsDisplayOpacity objects here will hurt d2d since we have to flush every time.
Whiteboard: [leave open]
FYI - This patch doesn't fix main problem like Matt Woodrow (:mattwoodrow) mention. Scrolling on this page seems better with patch, but unfortunately it's still feels heavy compared to disabled HW Acc.
Whiteboard: [leave open] → [Snappy] [leave open]
Can someone with privileges close this as RESOLVED FIXED?
with pleasure!
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Assignee: nobody → matt.woodrow
Target Milestone: --- → mozilla20
Whiteboard: [Snappy] [leave open] → [Snappy]
Thank you! Marking as VERIFIED as I can't reproduce the main problem anymore.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.