Fire Fox 17.0b4,16.02,16.01 cauising Windosw xp sp3 blue screen error

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: mac7595, Unassigned)

Tracking

16 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

126.19 KB, image/pjpeg
Details
(Reporter)

Description

5 years ago
Created attachment 680132 [details]
ff16.jpg

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; BTRS124828; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C)

Steps to reproduce:

Using vertical bar scroll, key board arrow keys and page up / down causes failure.  Regressed to FF 3.2.6.8 does not happened, IE 8 does not happened. Have uninstalled and reinstalled FF with same result. Have done registry clean, deleted/ reinstalled Norton fire wall antivirus. Have done reinstall of Windows xp sp3 and still get same result. Have  updated graphics driver with same result


Actual results:

Immediate shut down and upond restart windows does file check. Flying drive heads have not had time to park and see corruputed disk files. After re-start MS windows reports serious error and have sent twice. Screen shots attached
It seems that you did everything possible to fix it.
What you can try is to disable the graphic hardware acceleration in Firefox: options/advanced/general followed by a Firefox restart.

The only chance that you have if you still get a BSOD is to use the Microsoft debugging tools to find the crashing component of your system.
The error itself is only triggered by Firefox and is nothing that can be fixed in Firefox itself. We could only add workarounds for such system issues and it's only worth to invest the 10h-100 man-hours if this exact same BSOD happens on many systems.
e.g. all NVIDIA graphic card drivers are crashing.

I don't think that this is the case and there is nothing to do for us here.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

5 years ago
If triggered by FF means it is caused  by some type of program error especially since IE8 and FF 3.6 works OK. I use the NVIDA graphics card in 3d modelling and it works very well. I have tried to get the DR Watson report but for some reason it is not recording. Have the crash report dump but I don't have a binary debugger tool.
Since posting above I rolled back my graphics driver to earlier version and also disabled the directX accleration in the sytem. I think it is working now but it is not the graphics card because the later version of the driver I donwloaded just recently in the trouble shooting steps ,so my guess is you have an interface problem with DirectX application that is causing the trigger.
BTW :I have noted the scroll bar length seems variable when I have the problem and when not it stays fixed.
 I'll reinstall the graphics driver and see what the results are. 
I'll make the fix by un-installing FF and use IE because I cannot take the risk of the contuined hard disk flying head crashes and possible damage to my system.
A usermode application like Firefox can not freeze or crash a modern OS.
That's the difference between DOS/Windows9x/MAc classic and WindowsNT+, linux, OSX
Only drivers (graphic card, sound, networking, Firewall), the system itself or hardware issues can crash the OS.

That it works in IE or other version of Firefox doesn't matter at ll. It's just luck that they don't hit the same bug in your system.
You don't have to disable directx systemwide, you can disable it just in Firefox.

The OS vendor (micosoft in this case) usually provides help to debug issues like this but it's time consuming and you need some knowledge to do it.

It's sad but the only logical consequence for you is to avoid using Firefox as workaround if you can't find the reason for the crashes.

BTW: The graphic card driver is the most likely cause of a BSOD based on my experience. Disabling the hardware acceleration helps in many cases to avoid it to hit the bug in the driver.
(Reporter)

Comment 4

5 years ago
Suggest you read this https://msevents.microsoft.com/CUI/EventDetail.aspx?culture=en-US&EventId=1032298076&CountryCode=US.
I use a more pragamatic approach. It did not do before, others do not do know but FF does so with the new version. The os kernel mode has access to all the info including user kernel and if user is making some violation it may very well falut.
The MS OCA stats are :
75%
(Reporter)

Comment 5

5 years ago
Suggest you read this https://msevents.microsoft.com/CUI/EventDetail.aspx?culture=en-US&EventId=1032298076&CountryCode=US.
I use a more pragamatic approach. It did not do before, others do not do know but FF does so with the new version. The os kernel mode has access to all the info including user kernel and if user is making some violation it may very well falut.
The MS OCA stats are :
75%
(Reporter)

Comment 6

5 years ago
Sorry for double clutch!!
The MS OCA ( Online Crash Analysis)stats are :
75% caused by third party codes, usually drivers;
15% unknown( memory too corrupted);
10% hardware issues;
3% MS code.
Global statement FF cannot cause fault flies in the face of reality. This is just a excuse for people not wanting to face the truth. 
However, something has changed.  I can no longer force the fault at will when system is configured to my base line configuration but I did not have internet disconnected so may have received some updates form you I do not know about. Presently using 17.0.0.4693
>75% caused by third party codes, usually drivers;
                                  ^^^^^^^^^^^^^^^^
Firefox doesn't install any drivers or code that runs with kernel mode privileges.
That means that Firefox can not cause of a BSOD/crash/freeze of the os. It can however trigger a bug in one of the installed drivers and that's what's happening here.

We are not the support and do not provide help here. bugzilla is a tool for our developers to manage their work on the product. We can't fix a bug because it's not in our code = the bug gets marked invalid.

Read http://en.wikipedia.org/wiki/Ring_%28computer_security%29 if you want to know more.
(Reporter)

Comment 8

5 years ago
Thanks for your help. 
The reason I ref you to the above link is os kernel has access to all and if for some reason user  is doing somehting the os kernel is checking doing some thing than it will crash as victim but not the root cause.
Additional info for you:
Noted above was a change in my system performance.  This occurred when a new video driver was installed  and DirectX  acceleration was disabled. To check the  video driver was then  rolled back to the original version and no failures encountered and similarly  the DirectX acceleration was re_enabled and still no failures?? 
The windows debugger was down loaded (ref the above link to Mark Russinovich  Tech Ed presentation ) and evaluation of the Mini Dumps indicated the file nv4_disp.dll was flagged as possible cause of problem. ( Kernel dumps have not been recorded possibly because the page file min size was set too low. Symbol files are not available  also.) 
Form the  above time( ~10/20 to present) no failures have happened with the updated graphics driver and acceleration enabled.
Waiting to see if another failure can be trapped.
You need to log in before you can comment on or make changes to this bug.