If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Profile Manager, application window way too narrow

VERIFIED FIXED in M8

Status

SeaMonkey
General
P3
minor
VERIFIED FIXED
19 years ago
13 years ago

People

(Reporter: cpratt, Assigned: Dan M)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build ID: 1999061408
Platform: Windows NT

At first launch of apprunner, the CPM window is far too narrow; it's only as
wide as the word "Communicator".
(Reporter)

Updated

19 years ago
Summary: Colmmunicator Profile Manager window way too narrow → Profile Manager, application window way too narrow
(Reporter)

Comment 1

19 years ago
The same problem exists with the main application window itself.

Updated

19 years ago
Assignee: shuang → trudelle

Comment 2

19 years ago
This is a problem with all apprunner windows in today's build; they come up
normal size, then resize really narrow.

The problem occurs in nsWebShellWindow::SetSizeFromXUL(), where danm is calling
sizeString.ToInteger() on an empty string. Becuase of a bug in nsString2 (on
which I filed bug 8125), the error code is not being propagated back, and
get returned as the result of the function. So we try to set the window width
to a large negative number.

Updated

19 years ago
Assignee: trudelle → danm

Comment 3

19 years ago
reassigning to danm

Comment 4

19 years ago
rickg is checking in a fix for bug 8125 now, which fill fix the immediate
problem. However, you may wish to investigate why
nsWebShellWindow::SetSizeFromXUL() is now getting empty strings for height and
width, and handle the empty string case more gracefully. Note also the comments
in nsString2::ToInteger about passing in the radix.

Comment 5

19 years ago
Mass migration of minor danm bugs from M7 -> M8

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 6

19 years ago
Fixed the *real* problem which was in nsString2::ToInteger. I inadvertently set
the result value instead of the error code on badly formed input.

Comment 7

19 years ago
*** Bug 8426 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
QA Contact: cpratt

Comment 8

18 years ago
Moving UE/UI component bugs over to new User Interface: Design Feedback 
component.  UE/UI component will be deleted.
Component: UE/UI → User Interface: Design Feedback

Updated

15 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.