Last opened image is observed for a second, when we open gallery from camera preview.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Camera
P3
normal
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Inder, Assigned: djf)

Tracking

({hang})

unspecified
B2G C2 (20nov-10dec)

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.4 (KHTML, like Gecko) Chrome/22.0.1229.94 Safari/537.4

Steps to reproduce:

Steps to reproduce:
1) Open camera
2) Take a snapshot
3) Go to gallery 
4) Open the image
5) Go back to camera preview by touching the camera ion at the bottom
6) Go back to gallery


Actual results:

Observation:
Last opened image is observed for a second, when we open gallery from camera preview. After that, if we go back to camera by touching the camera icon at the bottom in Gallery and open gallery again from camera preview then last opened image is not observed.


Expected results:

We shouldn't see the last opened image in the gallery when the gallery is opened again in Step#6.
(Reporter)

Updated

5 years ago
Group: qualcomm-confidential
Priority: -- → P3
(Reporter)

Comment 1

5 years ago
Update: These steps mentioned above is now crashing the camera!
blocking-basecamp: --- → ?

Updated

5 years ago
Keywords: crash, qawanted
QA Contact: nhirata.bugzilla

Comment 2

5 years ago
I can't reproduce the crash. Can you give full STRs on the crash.
Created attachment 682210 [details]
logcat

I didn't see a crash, I see a hang of a black screen.  It looks like an OOM that's not being recovered correctly.  Note, I saw the main issue that this bug is referring to.  Also to note, I saw the last picture turned into the background image while switching from gallery to camera again.
Marking to new as I see the issue that was described.  removing crash and changing to hang.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash, qawanted → hang
(Reporter)

Comment 5

5 years ago
Seems like it's random. It happened to me again just now when after step#6 in Description I again went to preview. But, can't reproduce it in couple of more tries.
Btw, this is on Otoro.
I was using unagi and I experienced a hang.

To note for the last picture thing, you can hit the gallery and then select another image and you'll still see the last picture you viewed... Looks like a performance/memory/caching issue from what I can tell.
blocking-basecamp: ? → +
Priority: P3 → P2
Target Milestone: --- → B2G C2 (20nov-10dec)

Updated

5 years ago
Component: Gaia → Gaia::Camera
Assignee: nobody → dflanagan
Target Milestone: B2G C2 (20nov-10dec) → ---
I can reproduce the hang.

Any reason to keep this private?
Flags: needinfo?(mvines)
Group: qualcomm-confidential
Flags: needinfo?(mvines)

Comment 8

5 years ago
Let's focus this bug on the glitch and file a separate bug for the hang.
Priority: P2 → P3
Target Milestone: --- → B2G C2 (20nov-10dec)
split the hang issue as a separate bug 817211
I don't see this glitch anymore (when it doesn't hang, which I can no longer reproduce).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 11

5 years ago
Chris,

I fixed the visual glitch when it was pointed out during review of one of my memory-shrinking patches for #809782. Since this bug used to be mainly about a hang, I didn't come over here and verify that it was resolved.  Thanks for checking and closing.
You need to log in before you can comment on or make changes to this bug.