Build ID: 2001-05-15-08 on all platforms Summary: New Account button's text should read Add Account. Reason: "New" implies that we are creating an account (activation, etc.), but really all we are doing is adding a pre-existing account to the account manager. Changing this to Add Account is also the exact opposite of Remove Account, and would be more correct.
Index: AccountManager.dtd =================================================================== RCS file: /cvsroot/mozilla/mailnews/base/prefs/resources/locale/en-US/AccountManager.dtd,v retrieving revision 1.5 diff -u -r1.5 AccountManager.dtd --- AccountManager.dtd 2001/02/13 05:37:59 1.5 +++ AccountManager.dtd 2001/05/15 21:43:04 @@ -2,7 +2,7 @@ <!ENTITY accountManagerTitle.label "Account Settings"> -<!ENTITY newAccountButton.label "New Account"> +<!ENTITY newAccountButton.label "Add Account"> <!ENTITY setDefaultButton.label "Set as Default"> <!ENTITY duplicateButton.label "Duplicate"> <!ENTITY deleteButton.label "Remove Account">
17 years ago
Oh, and I'll file a bug on Bhuvan or me to fix the entity names to reflect the counterparts in the string that follows them. for example, <!ENTITY deleteButton.label "Remove Account"> should be <!ENTITY removeButton.label "Remove Account"> doesn't affect functionality, but is needed for cleanup.
bug 81043 has been filed.
I suggest disapprovement and that you retarget this for something else than 0.9.1 The spec says "Remove Account". So as long as you don't have jglick to either agree or change the spec, this must not go in.
I meant "New Account" there.
hwaara is right, get jglick to approval and update the spec first.
That is why both she and Robin are on this bug. Let me change the milestone so nobody goes postal.
"Add Account..." instead of "New Account..." is fine by me. As Håkan, suggests though, you might want to wait until after 9.1, otherwise, you'll have to get approval from international folks at this stage. Actually, I'd like to see "Add..." and "Remove...". The Account part isn't really necessary? These two buttons could go next to each other and reduce the horizontal space they take up. Especially since we hope to have "Move Up" and "Move Down" buttons added in the future (to re-order accounts). I'll update spec as appropriate. :-)
This bug might need to be morphed into a XUL bug and re-assigned to someone with a little more coding expertise ;-) Should we start a thread in mail-news or in UI?
prob Mail News?
I've started a thread.
17 years ago
Jennifer, can you (when you have time) make a proposal page for the current ideas you have with mockups?
Sorry, wrong screenshot, removing URL until I find out if one exists ;-)
mass accepting my bugs.
Re-assigning to Bhuvan. Bhuvan, would you have time to get to doing the full implementation of this? (It would rock ;-)
61078 already exists for reordering accounts, this bug would just be to change the text of Add and Remove Account.
Will you guys let me fix this now? Just the wording, and we can do the fancy button positioning later?
Taking bug. Jennifer can you review this please? Thanks.
Changing "New Account.." to "Add Account..." or "Add..." (and "Remove...") sounds good to me.
hopefully seth won't mind me helping out and sr'ing a UI bug. sr=mscott for the DTD change.
Fixed. Thanks to all.
Trunk build 2001-11-13-03: WinMe Trunk build 2001-11-09: Linux RH 7.1, Mac 9.1 Verified Fixed, (the buttons now state "Add Account" and the other "Remove Account").