bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Cost control app is doing unnecessary work on gaia startup path

RESOLVED DUPLICATE of bug 813243

Status

Firefox OS
Gaia::Cost Control
RESOLVED DUPLICATE of bug 813243
6 years ago
6 years ago

People

(Reporter: Margaret, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I noticed that during startup I'm seeing l10n.js load from these 4 files:
app://system.gaiamobile.org/index.html
app://costcontrol.gaiamobile.org/widget.html
app://costcontrol.gaiamobile.org/service.html
app://homescreen.gaiamobile.org/index.html

Two things here:
1) We should see if we can punt on loading widget.html until we're actually going to show the widget somewhere.
2) We should delay loading service.html if possible (at least after the homescreen loads), and I'm not sure why we're including l10n.js in that. I don't see it being used.

Updated

6 years ago
Component: Gaia → Gaia::Cost Control
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 813243
You need to log in before you can comment on or make changes to this bug.