If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[email] should not allow for moving email to the drafts folder

RESOLVED INVALID

Status

Firefox OS
Gaia::E-Mail
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-basecamp:-)

Details

(Whiteboard: testrun 4)

## Environment :
Unagi phone, build 20121109063059
 build 2012-11-09  06:43:08
  
## Repro :
1. launch email w/ email account
2. create an email to self and send
3. long tap on the email
4. select the email and select the move icon and move to draft

## Expected :
1. should get an error message saying can't move to drafts folder

## Actual :
1. it moves it to the draft folder and duplicates the email.

## Note :

Updated

5 years ago
blocking-basecamp: --- → ?
Blocking-  

Moving to drafts is not a common use case.
blocking-basecamp: ? → -

Comment 2

5 years ago
Unagi phone, build 20121217070202

No error message is displayed when moving emails to Drafts folder. User receives the message "X messages moved", but the message remain in the Inbox.
In Unagi version 20130104070203 the emails can be moved into the Drafts folder.

Comment 4

5 years ago
UCID: email-049
https://moztrap.mozilla.org/results/case/61760/
Whiteboard: testrun 2

Comment 5

5 years ago
Issue repros on unagi build 20130115070201 Kernel from Dec 5th

No error message is displayed when moving emails to Drafts folder. User receives the message "X messages moved", but the email message remains in the Inbox.

Comment 6

5 years ago
Issue repros.  When moving one or more emails to draft folder it is suppose to give you and error message but in reality it actually stay in inbox.  Also after moving there is a message that says " # messages moved".  
Build ID: 20130130070201
Kernel: Dec 5
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/4593f3e765eb
Gaia   f7f5a0cd17e3d04308cc5850b254947e127122b9

Updated

5 years ago
Whiteboard: testrun 2 → testrun 4
The test case is invalid; email-049 does not call for forbidding moving messages to the drafts folder.  No servers prevent us from moving messages to the drafts folder; I just tested on gmail and ActiveSync.  There's also no convention among e-mail clients to forbid such a thing, although I agree it's certainly not the type of thing that makes a ton of sense to do.

If we did have a requirement for avoiding moves to the drafts folder, we would implement it by not letting the user pick the drafts folder in the first case, not by generating an error message afterwards.


I think feature email-049 also doesn't make a ton of sense because of how we have structured our operations queue with retries.  By the time we know an operation has failed, a long enough time will have elapsed that it will be very hard to provide the user with context that the move failed.  It seems easier to keep quiet and let the user just notice that the message never moved.

Unfortunately, our interaction diagrams have disappeared from dropbox so I can't check whether this is something we need to change in the interaction diagrams or whether it was an invention of the feature transcription process.
The test case may be invalid, but the email duplication is still a bug imo.  You should be able to move the email without the email being duplicated; Thunderbird does not duplicate the email when you move it to the Drafts folder.
Email duplication is 100% a bug.  Please file a bug specifically about the duplication.  Please be sure to call out the account type domain in question as well as providing a logcat and whether this happens to be reliably reproducible for only the drafts folder, erc..  It would not surprise me if you are using a gmail account and gmail has some special handling for the drafts folder that causes duplication to occur.
Invalidating this bug.  Will report duplication issue separately if I can reproduce it in the current build.

Found an issue where I went into a state of a black screen with a stripe of email app on the left hand side, but cannot reproduce atm.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
I got the reverse issue.  I placed both emails (one from sent and one that I received because I sent it to myself) in the same folder and I only have 1 of those emails.

I moved an email from the All mail folder to the all mail folder and I lost that email.  2 separate cases.
Just an update/followup:

Reported the first issue in a different bug; cannot repro the second issue in today's build.

I don't see a duplication when moving to the drafts.  Even if that was the case, it probably would have been duped to bug 837263... If I find steps to repro duplication I will comment in that bug.

No further comments in this bug.
You need to log in before you can comment on or make changes to this bug.