Overlapping layers cannot be dragged

RESOLVED INCOMPLETE

Status

()

Firefox
Untriaged
RESOLVED INCOMPLETE
5 years ago
2 years ago

People

(Reporter: mgauthier, Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.0) AppleWebKit/537.11 (KHTML, like Gecko) Chrome/23.0.1271.64 Safari/537.11

Steps to reproduce:

In TinyMCE, I create two layers, placed one on top of each other


Actual results:

When I went to click and drag the layer that was on top of the other layer, the other layer gained focus, even though I clicked on the drag icon for the top layer


Expected results:

The top layer should be draggable after it was clicked on.
>In TinyMCE
Don't assume that everyone knows what TinyMCE is.

>I create two layers, placed one on top of each other

How do I do that ?
Please provide a URL with exact steps to reproduce and why Do you think that this is a browser bug (e.g. works in Browser X, worked in older Firefox version X,..).
Flags: needinfo?(mgauthier)
(Reporter)

Comment 2

5 years ago
Thank you for responding.

If you go to http://www.tinymce.com/tryit/full.php and clear everything in the WYSIWYG editor, click the layer icon and move the first layer around.  Then, click the layer icon again and move it so that the drag square is overlapping the other layer.  You will then not be able to redrag the layer you just placed on top of the other.
Flags: needinfo?(mgauthier)
I can reproduce the issue with Seamonkey trunk Clicking on the d&d area of the Layer box will give the focus to the underlying Layer box.
are are sure that this is a browser issue ?
I can't move the layer downwards with IE9 and can't move the layer area at all with Opera12.10
Hi Mgauthier,

I have tried to reproduce the issue using the provided link but it seams that the test page is no longer available. When I access the page, the link is changed in address bar. Can you please provide another testcase where I can check this on my environment ? 

Also, can you please test this on the latest Firefox release (43.0.4) or latest Nightly (46.0a1, https://nightly.mozilla.org/) and tell me if this still reproduces for you ? When doing this please use a new fresh Firefox profile, maybe also in safe mode (https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems). 

Thanks,
Cosmin.
Flags: needinfo?(mgauthier)
Considering the fact that the reporter did not provided more information on my request, I will mark this issue as resolved - incomplete. 
If you can still reproduce this, feel free to reopen it and provide the requested information.

Thanks,
Cosmin.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(mgauthier)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.