[i18n] Month names/dates in download manager in English (en-US) despite OS and browser being in a different language

RESOLVED DUPLICATE of bug 755224

Status

()

Firefox for Android
Download Manager
RESOLVED DUPLICATE of bug 755224
6 years ago
2 years ago

People

(Reporter: aryx, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme)

Firefox for Android nightly 20121111, Android 4.1.2 (stock), Google Nexus S

The downloads manager (about:downloads or menu Tools > Downloads) uses the English names for the months at which the download was done.

Android is set to German ("Deutsch", language code "de") and Fennec is multilocale build.

Updated

6 years ago
Component: Download Manager → de / German
Product: Firefox for Android → Mozilla Localizations
Version: Trunk → unspecified
This is no bug by the localizer (that's me) because the strings for month localizations are in http://mxr.mozilla.org/mozilla-central/source/toolkit/locales/en-US/chrome/global/dateFormat.properties which is localized: http://mxr.mozilla.org/l10n-central/source/de/toolkit/chrome/global/dateFormat.properties

aboutDownloads.js calls DownloadUtils.getReadableDates at http://mxr.mozilla.org/mozilla-central/source/mobile/android/chrome/content/aboutDownloads.js#323

DownloadUtils calls aDate.toLocaleFormat("%A") which shows the English weekday name: http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/downloads/DownloadUtils.jsm#346
For downloads older than a week, it shows the English month name using aDate.toLocaleFormat("%A"): http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/downloads/DownloadUtils.jsm#349

In jsdate.cpp, ToLocaleHelper gets called: http://mxr.mozilla.org/mozilla-central/source/js/src/jsdate.cpp#2916

And there PRMJ_FormatTime doesn't seem to return the expected result.

And yes, general.useragent.locale is set (by default) to |de|.
Component: de / German → Download Manager
Product: Mozilla Localizations → Firefox for Android
Version: unspecified → Trunk
This is basically a dup of bug 755224, but its in a different component. Localizing dates ends up calling strftime. I wonder if Android isn't setting the system locale, but using some custom abstraction.

I think we'll have to JNI this call to use something in Android instead.
Thanks. That's the reason why I didn't find it. It's always fun to dupe against oneself.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 755224
You need to log in before you can comment on or make changes to this bug.