Closed Bug 810734 Opened 9 years ago Closed 9 years ago

Infinite loop for parsing metadata of a mp4 file with zero size

Categories

(Firefox OS Graveyard :: General, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-basecamp:+, firefox18 fixed, firefox19 fixed, firefox20 fixed)

RESOLVED FIXED
blocking-basecamp +
Tracking Status
firefox18 --- fixed
firefox19 --- fixed
firefox20 --- fixed

People

(Reporter: sinker, Assigned: sinker)

References

Details

Attachments

(1 file, 1 obsolete file)

If you push an empty MP4 file (0 byte) to the device, gecko would run into an infinite loop for parsing meta data of the container.  Root cause is MediaStreamSource::readAt() is not aware of EOF of the container.
Blocks: 798448
Thanks Thinker! Is this patch ready for review?
Attachment #680495 - Flags: review?(chris.double)
blocking-basecamp: --- → ?
blocking-basecamp: ? → +
Assignee: nobody → tlee
Attachment #680495 - Flags: review?(chris.double) → review+
r=doublec
Attachment #680495 - Attachment is obsolete: true
Attachment #683902 - Flags: review+
Whats the status here? We need this _urgently_ landed.
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/414dab54c904
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.