[keyboard]Cannot delete the text in a text field with Chinese Pinyin Keyboard

VERIFIED FIXED

Status

Firefox OS
Gaia
--
minor
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: yxl, Assigned: yxl)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [label:Keyboard & IME])

Attachments

(1 attachment)

## Repro
1. enable Pinyin keyboad in keyboard settings
2. focus a text field and switch to the Pinyin keyboard
3. input any text to the text field
3. click the backspace key to delete the text inputed

## Expected:
The text in the text field is deleted.

## Actual:
No text is deleted.
(Assignee)

Updated

5 years ago
Whiteboard: [label:Keyboard & IME]
(Assignee)

Updated

5 years ago
Assignee: nobody → xyuan
Created attachment 680522 [details]
Github https://github.com/mozilla-b2g/gaia/pull/6135

Chinese Pinyin IME is not in the scope of v1, but we would have to keep maintain it (without conflicting with shipping product) until product branch is created.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Bug in jspinyin
User impact if declined: Chinese pinyin IME will be broken when step STR is used
Testing completed: yes?
Risk to taking this patch (and alternatives if risky):
Attachment #680522 - Flags: review+
Attachment #680522 - Flags: approval-gaia-master?(21)

Updated

5 years ago
Component: Gaia::System → Gaia
Comment on attachment 680522 [details]
Github https://github.com/mozilla-b2g/gaia/pull/6135

one liner that fix a file that won't be used in production. a=me.
Attachment #680522 - Flags: approval-gaia-master?(21) → approval-gaia-master+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/6135
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED

Comment 5

5 years ago
Device: Unagi
Build: 20130113070202
Does not reproduce on this device as option is unavailable.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.